Oracle doesn't show up in database connection with docker image(solved)

Hi all, I am trying metabase with docker, and can not find Oracle in my database connection field.

I follow this url:
https://www.metabase.com/docs/latest/operations-guide/running-metabase-on-docker.html#adding-external-dependencies-or-plugins, download ojdbc8.jar, put it in my centos’s /root/plugins, and run docker like this:

docker run -d -p 3000:3000 -e "MB_PLUGINS_DIR=/plugins" --mount type=bind,source=/root/metabase/plugins/,destination=/plugins --name metabase metabase/metabase

well, metabase started successfuly, but no oracle in my database connection.

I found some topics in this forum, and make ojdbc8.jar 777 in both my centos and metabase in docker, after restart docker, still no oracle shows in database.

So, any suggestions? Thanks!

Ye, I solved this, by reading this :Connection to Oracle Database

My /app/plugins directory has no permission to write, and the log in metabase shows:

[df7ff838-bcf6-4230-9169-1320b20f067f] 2020-02-05T00:01:35+08:00 WARN metabase.plugins Metabase cannot use the plugins directory /app/plugins
Please make sure the directory exists and that Metabase has permission to write to it. You can change the directory Metabase uses for modules by setting the environment variable MB_PLUGINS_DIR. Falling back to a temporary directory for now.

So, my be this url can notice newbie to attention on permision?

Thanks.

I am happy my thread helped you! Good luck in using Metabase!