Oracle doesn't show up on my database menu

Hi guys,

I was setting an env test to work with oracle database. So far, I did the configuration as suggested at:

But, still not seeing Oracle as an option on my database type tab.

Besides, I downloaded two versions of oracle driver just to be safe:
bash-4.3# pwd
bash-4.3# ls -la
total 6300
drwxr-xr-x 2 root root 4096 May 19 16:05 .
drwxr-xr-x 1 root root 4096 May 19 18:58 …
-rwxr-xr-x 1 root root 2739670 May 18 21:21 ojdbc6.jar
-rwxr-xr-x 1 root root 3698857 Apr 6 17:38 ojdbc7.jar

Thanks in advance

No one ever faced this problem before?

I have same problem.
I have an metabase installation based on docker image 0.24.2.
I follow the installation statement for oracle driver but when I try to create a database link I don’t see oracle menu choice.

Have you guys already followed these instructions?

Yes Maz. I did.
I tried several way.

  1. Insert driver file in the /app/plugins directory of the docker image
  2. Create a folder out of the docker and set MB_PLUGINS_DIR to point at this folder

Did you test oracle driver with docker?

I could resolve this issue defining the “env var” MB_PLUGINS_DIR inside the

1 Like

I’m available to test your solution.
Maz thank you very much for your fast feedback.

I had the same problem with the Docker installation. What I needed to do to fix it is:

  • Make sure the metabase account in the Docker container can actually access those files, for example chmod -R 777 ./plugins on the host. You can verify this with docker exec -it metabase ls -l /app/plugins.

Hi Maz,
I read instructions and do not realize how the new jar(in plugins folder) will be associated to text in the combo box. Normally in a combo is displayed human-readable description ( like PostgreSQL, MySQL) and NOT the driver name. So even Metabase to load dynamically new jars( db drivers), there should be simple configuration and mapping between these jars and text displayed in combo. My question is: where should I add this mapping in order to use provided in plugin DB driver?

If you just want to use an already supported database like Oracle there is no need to give any mapping as it’s already hard-coded into the Metabase driver layer (a support layer on top of e.g a JDBC driver) - like here for Oracle. So there is really no magic to it.

Hope that explains …

Thanks for fast reply! Unfortunatelly this is not the case. I’d like to add snowflake connection. Is there someting I can do without waiting the official (hardcoded?) release. I do not know clojure but I’m prety good with java.

Well the code is already written - but pending tests. So if you got Java skills I guess you can get the build environment setup and can take this PR for a spin:

edit The PR has a pointer to dev environment instructions. But an even easier option IMO to sort dev dependencies is to use the awesome (latest version in master is improved compared to the PR)