Ordinal values reformatted and come out faulty

Hi, First time using Metabase and it looks very good for the purpose. While rebuilding reports in Metabase I encountered an issue with displaying Ordinal values as Opposed to a Timeseries on the X-Axis.
The char(7) field used is formatted YYYY-DD and represents monthly results. I need the year-month below each column. Can’t do with less precise and fewer Timeseries labels. The result though is the for instance “2019-08” is being reformatted as August 1, 2019, 12:00 AM. This would suggest results up to July 2019. Basically the results shown in the chart are all ‘shifted’ by one month.

How do I get Metabase to display ordinal values as they are? In this case, YYYY-MM as they are stored in the database and not displayed as a misleading date.

Thanks,
Michael

edit: specified that the column discussed is char(7)

Hi @Michael

I replicated your question here and that is a bug when you try to build the chart by native query.
But if you try to build the chart by the Custom option, maybe you could have the result below:
I used the sample data available for metabase

Let me know if helped you

Regards

Hey Frederico thanks for givin it a go! Your result would be acceptable.

Unfortunately I still see the same effect. The query is basically selecting all rows from a view.

(I hope pasting the screenshot works like this…let’s see)

/Users/michael/Pictures/SnapNDrag Library.snapndraglibrary/dd973f754-e3/screenshot_99.png

1 Like

Actually I have this bug not when building a Native query. I used the Simple question option. And then selected the view (where all the complex logic resides)

1 Like

Looking how you made it work Frederico, I think you group by an actual date field. At this point Metabase is smart enough not to pick an actual date since the grouping is by month.
In my case I have a char(7) column with something similar enough to a date and Metabase wants to be smart. Unfortunately :-(. Perhaps I reformat the column by adding a dash or asterisc in fron…hopefully Metabase then leaves it alone.
Unless this is a setting somewhere I could manipulate (what I was hoping for)

1 Like

@Michael I think you’re seeing this issue - upvote by clicking :+1: on the first post:
https://github.com/metabase/metabase/issues/11069

1 Like

That’s it! I didn’t find that. Thanks I’ll upvote!

For now I proceed like this

/Users/michael/Pictures/SnapNDrag Library.snapndraglibrary/dd99a6fe8-52/screenshot_108.png