Password reset seems to be reseting on wrong database?

Hello. I have the opensource version of Metabase installed locally on my computer. I have also locally installed a postgres database on my computer to be used as the applications database. I have set up a service to point the Metabase application to the postgres database using some environment variables. This has worked very well for a while now.

I received a new computer and so I have been porting over the installation to the new computer. I have everything set up as I had in the old computer, including moving the postgres database over to the new computer.

It seems that my password isn't working, so I wanted to reset it. I have followed the instructions here. It seems the password reset was successful and I got a token.

When I go to: http://localhost:3000/auth/reset_password/1_1bc4d879-f234-4cb7-bdde-fb5da35643cd

I get a message that says:

Whoops, that's an expired link

For security reasons, password reset links expire after a little while. If you still need to reset your password, you can request a new reset email.

I had a look into the postgres database and I can see my user information stored in the core_user table, so I know that got ported over. When I look at the messaging from CMD, it almost looks like it tried to reset the password from the old H2 database and not the postgres database that I have migrated to. I've been digging around here for a while, trying to figure out what is happening (or why this is happening), but haven't been able to find any online resources. I appreciate any help.

Print out from CMD (changed the password print out for privacy reasons):

2022-11-04 09:13:11,922 INFO metabase.util :: Maximum memory available to JVM: 247.5 MB
2022-11-04 09:13:20,884 INFO util.encryption :: Saved credentials encryption is DISABLED for this Metabase instance.
For more information, see Redirecting…
2022-11-04 09:13:22,931 INFO driver.impl :: Registered abstract driver :sql
? Load driver :sql took 416.9 ms
2022-11-04 09:13:22,937 INFO driver.impl :: Registered abstract driver :sql-jdbc (parents: [:sql])
Load driver :sql-jdbc took 527.5 ms
2022-11-04 09:13:22,941 INFO driver.impl :: Registered driver :h2 (parents: [:sql-jdbc])
2022-11-04 09:13:22,955 INFO driver.impl :: Registered driver :mysql (parents: [:sql-jdbc])
2022-11-04 09:13:22,968 INFO driver.impl :: Registered driver :postgres (parents: [:sql-jdbc])
2022-11-04 09:13:24,773 INFO metabase.core ::
Metabase v0.42.2 (d6ff494 release-x.42.x)

Copyright ⌐ 2022 Metabase, Inc.

Metabase Enterprise Edition extensions are NOT PRESENT.
2022-11-04 09:13:24,785 WARN db.env :: WARNING: Using Metabase with an H2 application database is not recommended for production deployments. For production deployments, we highly recommend using Postgres, MySQL, or MariaDB instead. If you decide to continue to use H2, please be sure to back up the database file regularly. For more information, see Redirecting…
2022-11-04 09:13:24,787 INFO db.setup :: Verifying h2 Database Connection ...
2022-11-04 09:13:24,962 INFO db.setup :: Successfully verified H2 1.4.197 (2018-03-18) application database connection.
2022-11-04 09:13:24,963 INFO db.setup :: Running Database Migrations...
2022-11-04 09:13:24,966 INFO db.setup :: Setting up Liquibase...
2022-11-04 09:13:24,991 INFO db.setup :: Liquibase is ready.
2022-11-04 09:13:24,992 INFO db.liquibase :: Checking if Database has unrun migrations...
2022-11-04 09:13:25,926 INFO db.setup :: Database Migrations Current ...
2022-11-04 09:13:25,940 INFO :: Running all necessary data migrations, this may take a minute.
2022-11-04 09:13:25,945 INFO :: Finished running data migrations.
Database setup took 1.2 s
Resetting password for

2022-11-04 09:13:26,111 INFO driver.impl :: Initializing driver :sql...
2022-11-04 09:13:26,112 INFO driver.impl :: Initializing driver :sql-jdbc...
2022-11-04 09:13:26,113 INFO driver.impl :: Initializing driver :h2...
OK [[[1_1bc4d879-f234-4cb7-bdde-fb5da35643cd]]]

Hi @rossi45
You can more Metabase as much as you want, as long as it's the same application database, then all your logins etc will stay exactly the same and won't require you to do a password reset.

You are not using the Postgres as application database anymore, so I guess you are missing some environment variables:

Also, you are starting Metabase with way too little memory - it only has 250MB available.