Performance issue with metabase v0.45.2 (Containerized)

we are facing performance issue when we deploy metabase newer version (v0.45.2) with containerized metabase and mysql database version v5.7.7 also a container on eks cluster and the database is provisioned with persistent volume on aws and metabase running with java version

, we are comming from version 0.42.4 and the setup is up and running and we didn't face any performance issue before and here's the java version for the earlier metabase version

i dunno why mysql container reaches its memory peak and then crashes and keep doing this stuff also we tried to deploy mysql database as container on eks with the recommended version and another version and its keep doing the same behaviour and here's some cpu and memory utilization from grafana

interesting, this is the first time someone reports this. Is this in the startup of the container? when does this happen?

@Luiggi nope the containers going up smoothly but when i stress test on metabase and running multiple queries at the same time for many taps the database going crazy and thats leads to crashes

what's the sizing of the database?

mysql> SELECT table_schema "metbase", ROUND(SUM(data_length + index_length) / 1024 / 1024, 1) "DB Size in MB" FROM information_schema.tables GROUP BY table_sChema;
| metbase | DB Size in MB |
| information_schema | 0.0 |
| metbase | 12243.3 |
| mysql | 2.8 |
| performance_schema | 0.0 |
| sys | 0.0 |
5 rows in set (0.19 sec)

thanks, and what about the resources? cpu/ram/disks

Do you have any Oracle database configured in your Metabase?

I was facing the same issue with containerized metabase and saw your post yesterday. I was getting a frequent error in the log (Locate not recognized) when this connection was requested. The reason for this was the difference between the timezone in the Metabase and the timezone in the container.

For some reason, when the connection was requested, the error didn't happen immediately and the processes kept running, resulting in many concurrent processess, including sync and scan databases (known as heavy processes).

Modifying the timezone on container solved the issue. Perhaps you can try this approach even if you don't have an Oracle connection.

@Luiggi for database container we're using cpu and memory limits in Kubernetes , the stable version runs with resources as the following :
CPU : 3 cores
memory : 10 GB
however Metabase container not facing and issues with it
but when upgrade to specified version the database container sent to the grave :smiley: , we tried to scale the resources up and the same behavior happened .

hmmmmm interesting , although we don't run oracle databases but might be some issues with the time zone configuration with my containers i'll check it and come back to you

@Deivisson i checked my timezone configuration and it's all set up so i don't think it's a matter of time config ,thanks for your help .

as this is the first time I see this issue, it might be some issue with the MySQL version. Is it possible to upgrade MySQL to the latest version?


You're welcome!

Although this treatment works at first, the error happens again after a while.

I'll create a new thread about it.

i'll check this solution and reply back to you

hmmmm sadly :confused:
could you please share with me updates about it as my error is similar to your case

I created a topic about my issue: Oracle Connection Issue - Locale not recognized - #5 by noritomi

I have to do some tests to eliminate some possibilities, but I still couldn't understand the cause of the problem.