Please, stop the timezone thing!

Guys, isn’t it possible just to turn out for good any timezone conversion metabase might be doing?

Check this (please ignore the minutes difference, focus on the hour):

This is not what the datebase returns. This is the converted version of what database returns, and I don’t like that. I want my queries running exactly the same in Metabase and in SQL client.

And, more than that, metabase is not converting every single datetime field. So:


If you tell me that I can just leave the general timezone configuration set to “database default”, I will say that it is not right. Check the results of these two simple questions with and without the timezone configuration set properly to date filters (for clarification, the chart is based on native SQL question that returns only hours from midnight and forward):



It shifts two hours and messes my questions completely; this behaviour was not there in 0.29, and It felt just fine.
I don’t like this behaviour. That scares me, specially considering that metabase is not converting every single datetime; so far, it converts the “now()” return, but, I wonder, what else will it secretly convert and I won’t notice?
I want every timezone conversion turned off in metabase - I would like to handle that myself. Is that possible? For me, it is a matter of reliability - if I am not quite sure about what, why and when metabase is performing time zone conversion, I don’t trust it to perform none… Seems to me like a feature that is causing more harm than good. Or, I am completely missing the point of how it works - I never discard this option lol

Even i am facing the same issue … is there any work around ?

Not that I’m aware of. As far as I know, you can set the timezone to your correct timezone and hope for the best. For me, as described, it is working with the proper timezone, although I’m not entirely sure about what is being converted, or when.

Even though i have selected the Asia/culcutta as my report time zone i am getting date in the report like “2018-12-01T05:29:59.000+05:30” which i suppose to get “2018-11-30 23:59:59”

Even i tried with the default database then also result is same “2018-12-01T05:29:59.000+05:30” which i suppose to get “2018-11-30 23:59:59”.

Please help us out

A few questions:

  • where is your metabase instance running?
  • in your metabase environment, what is the timezone? (for instance, I run my metabase instance on an Amazon EC2 instace, which has the timezone set to “America/Sao_Paulo”)
  • what is your database timezone set to? (mine is set to UTC)

where is your metabase instance running?
AWS instance
in your metabase environment, what is the timezone?
what is your database timezone set to?

Er… ok… you said “getting date on report like this and not that”
How is that report? Custom ou native question? Have you tried date formatting options?

Also, if you haven’t so far, check this:

I’m not sure how to check it, but the JVM may impact your results as well. It is worth checking (although I’m not sure how to do that - I’d need to google it myself).

Ok thanks . I will go through it :grinning:

ya its a Custom and even in the native i managed some what using sql date_format.
But got struck in Custom :neutral_face:

Is there any help on this …?

Hm, I kinda haven’t had problems with that anymore, so I didn’t really look up any more - and, also, I haven’t come across any open issue or something related to this. If you’re still having problems, it might worth to file an issue on GitHub.