Postgres "Relation <tablename> does not exist"

Hi all, I am kicking the tires of Metabase with a local JAR based install. I connected to our AWS RDS Postgres instance. It fails to sync the schema, every table shows this error in the Metabase console output:

2022-05-05 11:18:24,227 WARN sync.util :: Error syncing Fields for Table 'Table 20 'ctgprod.pricing''
org.postgresql.util.PSQLException: ERROR: relation "pricing" does not exist
  Position: 19

Some online reading suggests these error are common in Postgres when there are upper/lower case issues with table names, but all our table names are fully lower case. And I see the schema is specified, so that is not the issue either.

Must be a common problem, but I cannot find anything here in the discussion groups or on the web.

Hi @mark2
Please post "Diagnostic Info" from Admin > Troubleshooting.
What type of columns does "pricing" have? If it has JSON columns and you're using 0.43.0, then I think you're seeing this issue, which I haven't had time to debug yet:

Thanks, yes, that looks like the issue. We have JSONB columns in most of our tables and they are not in the default public schema. Troubleshooting data below. The issue indicates there is a workaround with an 'option' string, how would I do that?

  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.75 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "Cp1252",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "",
    "": "Windows 10",
    "os.version": "10.0",
    "user.language": "en",
    "user.timezone": "America/New_York"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
    "run-mode": "prod",
    "version": {
      "date": "2022-05-02",
      "tag": "v0.43.0",
      "branch": "release-x.43.x",
      "hash": "ee686fc"
    "settings": {
      "report-timezone": null

@mark2 You can set the Connection String via Admin > Databases > (your-db) > Advanced > Connection string.
But I cannot say if the workaround will cause other problems.

I've not been able to reproduce the issue as of yet. And I'm not using "public" schema, so I'm still unsure what it takes to make it explode.

OK, that seem to get it working. Thanks.