"Problem connecting to LDAP server: User search base does not exist or is unreadable"

I have connection problem when setting up LDAP in Metabase.
My search base is

   OU=*User Accounts,DC=myDomain,DC=com

But I get the error in the title. Since there is a space in OU name, I tried putting it in quotation marks, or escaping it, but it didn’t work.

I tested the connection with AdFind.exe and it’s working fine there:

   ./adfind.exe -b "OU=*User Accounts,DC=myDomain,DC=com"

Any help would be appreciated.

Hi @King_Edward
It’s been a long time since I played with LDAP, but I remember that special characters (like space) are escaped with backslash \
Have you tried OU=*User\ Accounts,DC=myDomain,DC=com ?

Yeah, that wasn’t working either.

Actually, I tried with “CN=Users,DC=myDomain,DC=com”, and still the same problem. So the issue wasn’t the space.

Interesting. Which version of Metabase? Do you see any other errors in the log?

Found it. The problem was that I hadn’t indicated the username that is used to lookup information about other users, because our AD admin had said it is not needed!

Sorry about that.

1 Like