Problem to load data from BigQuery


I am unable to load data in Metabase, that is stored in a google sheet in Big Query. I can run and display the query in Big Query but in Metabase I keep getting the error message “question took too long”. The Metabase logs state “WARN metabase.query-processor :: Query failure: Read timed out”

The table actually contains only a little amount of data, and I cannot figure out why it cannot be displayed in Metabase.

Does anyone have an idea of how to solve this?

Ive had a similar issues when filtering by date range - metabase sends a SQL cast query which bigquery struggles with. I havent fixed it but think the solution is to store dates as type: DATE inbig query to avoid the cast.

Thanks, I have just tried that and it does not make any difference unfortunately. So the source of the problem must be something else

Hey Helen,

I had a similar problem… It ended up being a Google authorization issue.

How are you loading data into your Bigquery tables?

It is created as a table directly in Big Query.
Source is Google drive and the file format is Google sheet.

Same issue I had. It’s a permission issue with Google Drive.

Reconnect your Bigquery data source this time enable Google Drive permissions when prompted in the API.

Thanks for that! I tried that too, but it still does not work.