Problems with pulse email setup

Hi,
I keep getting message “Sorry, something went wrong. Please try again.” when setting up a basis SSL outgoing configuration. I have tried this config in another unrelated program and it works fine. How can I debug this? or are there common setup problems in Metabase?

thanks much
Charles

Hi @crwheelr
Which version of Metabase?
What do you mean with “basis SSL outgoing configuration”? Are you talking about outgoing proxy?
You should see more detailed error information in Admin > Troubleshooting > Logs.

Hi @flamber,

its version 32.7. no there is no proxy involved. I was referring to SSL encryption

SMTP smtpout.secureserver.net
port

SMTP smtpout.secureserver.net
port 465
send address the account email address and password

I use the same setup params on my web camera that sends alarm events and it checks out.
any ideas.

thanks
Charles

@crwheelr
Okay, the latest release is 0.32.9, so even though I don’t think there’s anything fixed related to emails, I would recommend that upgrade.
But check your Metabase log for more details.
Since you’re using the same configuration for your webcam, then it is most likely a software firewall that is blocking the Docker or JAR or however you’re running Metabase.

@flamber,

I got the smtp server email working, but only with unencripted port 80, 3535, and 25. SSL encripted with port 465 does not function as cannot save email setup. i disabled windows and router firewall completely to no avail. i’m fine with unencrypted, but i think it might be a bug.

unrelated question if you would, if i want to relocate my sqlite database to another location, without loosing all that has been setup with metabase, what method should I use?
thanks
Chuck

@crwheelr
Without any logs, it’s really difficult to figure out what’s going on. What “SMTP Security” did you select? I think most providers are using “TLS”.

As for moving SQLite, you should be able to do that without any issues, simply moving the file and then changing the path in Admin > Databases > (sqlite)
But as with any big changes, always make a backup before starting.

@flamber,

I checked the log for SSL connection that fails. "fail to connect to server, " comes up. not so with unencripted setup.

another quick one please. with the latest version (i think) the hidden fields disappeared from admin/datamodel form. I need to make a previously hidden field visible and cannot see the hidden field anymore… Tried selecting the hidden filter up top but nidden fields are not shown. any ideas? this is with SQLite
Chuck

@crwheelr
Okay, but you’re not answering the question. Which “SMTP Security” have you set in the Metabase email setup?

Visibility options in Data Model has not changed for many versions, so you should still have the two types of visibility - tables and columns. This is how it looks in 0.32.9:


@flamber,

SSL security is what i initially had set, and port 465 which is specified by the email provider… was not able to save an email setup that way, however, with no security it worked. If you want my credentials to see this for yourself i will email you privately my credentials

or the columns visibility, i can only see columns classified as ‘everywhere’ and not the other ones. If I select the 'Hidden" filter, the columns below are all greyed and again, only the ‘everywhere’ columns are shown. So I tried the “show original schems” to look at the columns. there are 32 recognized by Metabase, but in fact there are 78 columns in the table. the difference between 78 and 32 are columns that I defined as hidded at one point, and now cannot be recognized. do you think i will need to start over, to get all the columns back? there is critical one i need now. write a python script to populate that new column to facilitate Matabase analytics.
Charles

@crwheelr
You should never ever send your credentials to anyone.
Can you link to the help article of your provider, where it states that you should be using SSL on port 465?
I’m fairly sure SSL is not being used by any big providers anymore - everything is TLS nowadays. Or maybe STARTTLS.

Okay, now I see what you mean with setting “Do Not Include” actually hides the column in Data Model if you refresh the browser. That definitely seems like a bug.
You would have to change visibility directly in the internal metadata database. Look in the table metabase_field for the column visibility_type where rows are set to sensitive and change those to normal

Here’s the godaddy business email setup link. see box circled in red https://in.godaddy.com/help/manually-add-email-account-to-outlook-2016-windows-28021

regarding edit of metabase database, I only know how to use razorSQL somewhat. there are multiple setup strings needed to setup an access profile. Maybe i can edit directly from metabase or else if you might suggest a means for easy profile setup and edit. thanks.
Chuck

@crwheelr

If TLS or STARTTLS doesn’t work, then I’m not sure why it doesn’t connect to GoDaddy.
It would require Wireshark or similar tools to check what’s going on with the connection.

I guess you’re using the default H2 database for metadata? If you don’t know, then it’s a yes.
If so, then it looks like razorSQL supports H2, so depending on how you’re running Metabase would define where the H2 file location is, but you just need to shutdown Metabase before editing the file (and of course make sure you do a backup first!).
As a note, I’ve create a bug already: https://github.com/metabase/metabase/issues/10297

flamber,
I closed the database and setup razorsql for my local H2 database, closed the database, I assume just by closing the CMD window in windows. after connecting, I can see the structure Information Schema and Public, with sections tables, views, system tables etc under that, but all sections appear as empty. nothing as all to see or modify. any thoughts on that?
Charles

@crwheelr
Okay, it is not recommended to use H2 in production environment, but should be migrated to Postgres or MariaDB/MySQL.
If you continue to use H2, it should be in Schemas > PUBLIC > Tables > METABASE_FIELD
I’ve just downloaded razorSQL and tested by connecting to a test H2 database, so it works.
Are you sure you’re using the H2 file that Metabase is actually using for metadata?

EDIT: Make sure Metabase is not running. I don’t know how you’re starting Metabase, but a very simple test is just to refresh the browser after you’ve closed the cmd window - if you get a could-not-connect error, then you’ve probably closed Metabase.

@flamber,

regarding RazorSQL, I create a profile using the H2 Embedded connection type, give my login credentials, and browse the metabase.db.mv.db file. when the profile is created and I connect to it, i can see that a NEW file metabase.db.mv.db.h2.db got created in the same folder. also a file . metabase.db.mv.db.lock.db got created, both of these by Razor. Somehow my browsed file is being interpreted as this one. does that make any sense?

If this is too much trouble, perhaps i can redownload the May version of metabase.jar as this one didn’t have the problem of supressing the hidden columns.?

Chuck

@crwheelr
I don’t know razorSQL, I just did a quick check without using any profile or inputting any credentials, since metabase.db.mv.db created by Metabase does not have a username/password. I seems like you’re creating a new empty database instead of loading an existing.
You can download any older versions - just replace the version number with the one you want:
https://downloads.metabase.com/v0.32.9/metabase.jar
Always make a backup of your metadata before upgrading/downgrading !

Just quick update on the earlier reported bug. The May version allowed editing the field from hidden to viewable in admin/datamodel tab. The current version does not have the previously hidden field visible to modify. So to get around it, I reverted to May version, made fields visible that I needed, and then went back to current version.

Chuck

1 Like