Public embedding on normal edition hosted on Heroku doesn't work

Hello everyone,

I'm using Metabase normal edition and it's hosted on Heroku using the guide from Metabase documentation.

First, here is my diagnostic info:

"browser-info": {
"language": "fr-FR",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like 
Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "1.8.0_322-heroku-b06",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "",
"java.version": "1.8.0_322-heroku",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "25.322-b06",
"": "Linux",
"os.version": "4.4.0-1101-aws",
"user.language": "en",
"user.timezone": "Etc/UTC"
"metabase-info": {
"databases": [
"hosting-env": "heroku",
"application-database": "postgres",
"application-database-details": {
  "database": {
    "name": "PostgreSQL",
    "version": "13.6 (Ubuntu 13.6-1.pgdg20.04+1)"
  "jdbc-driver": {
    "name": "PostgreSQL JDBC Driver",
    "version": "42.2.23"
"run-mode": "prod",
"version": {
  "tag": "v0.42.2",
  "date": "2022-02-28",
  "branch": "release-x.42.x",
  "hash": "d6ff494"
"settings": {
  "report-timezone": null

I want to share some questions / dashboard within an external blog / website. I followed all the steps indicated in the public sharing documentation.
I enabled public sharing in admin settings, and I tried to enable public sharing on one of my questions.

If I try the public link in another browser / private window, I have no issue seeing the question, as per example:

However, I can't make the public embed code work... Whatever the method I'm trying to use, the iframe code is never working:


My goal is to use these iframes in some other websites but nothing is displayed.

Could you please help me?

Thank you,

Hi @scapeshift
Check your browser developer console.
Make sure your Site URL actually matches how you are accessing Metabase. It should be https.

1 Like

Holy f*** really it's working now by using https instead of http.
I would have never been able to see this error myself.

Thank you very much!!!

PS: I did not find how to flag your answer as the solution nor how to close my post.