Public GUI filters not working


I have a public url exposed with parameterized input from the GUI of metabase i want to use that in angular application by allowing user to put values in text field and search and then try to export.
But as it's coming in the query string even some values are put in the text box it shows the old data(with the filter from query params).
Is there any way we can change the behavior or i am missing some details?
I tried using public apis also to make use and pass parameters but that also didn't help.
Please guide.

Hi @smishra
Are you sure that it's the same filter? One is number_of_days the other is No_of_days
Perhaps I don't understand what you're trying to do.

Hi @flamber,

Yes that is the same filter.
What I am trying here is to render the metabase GUI which gives as a public link and either try to render it as a iframe or public page where user can filter the data by keying the data in provided GUI (metabase) text field by keying some value.
when i do that the data is not returning according to the input params.
always it takes from the query string even for iframe.
Is there any way i can update the query string if filter changed by external user.

If you can provide one working example of metabase GUI with filters applied and getting correct that that's what i am trying to achieve.
I can create my own GUI and take inputs and call the public api's but checking if there in any feasibility by using the GUI provided by metabase with custom filter (user input filters)

Post "Diagnostic Info" from Admin > Troubleshooting.
And does the filter work normally in-app (not via Public Sharing)?

Yes the filter applied in the app works when we modify the value but not in public sharing neither url not iframe
Diagnostic Info

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36 Edg/95.0.1020.44",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "1.8.0_302-b08",
"java.vendor": "Red Hat, Inc.",
"java.vendor.url": "",
"java.version": "1.8.0_302",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "25.302-b08",
"": "Linux",
"os.version": "3.10.0-1160.42.2.el7.x86_64",
"user.language": "en",
"user.timezone": "America/Chicago"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "12.3"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
"run-mode": "prod",
"version": {
"tag": "v0.40.0",
"date": "2021-07-08",
"branch": "master",
"hash": "961caed"
"settings": {
"report-timezone": null

@smishra Okay, please try latest release, 0.41.1, since there was several filter problems in 0.40:

Sure i will try this Thanks @flamber

@smishra And while you're at it, then upgrade to Java 11 too:

Thanks @flamber for the help.
I have upgraded metabase to version v0.41.2 and seems date filter and all works fine for public URLs now.
Thanks a lot for the help.