Public link to metabase dashboard time out / error

When enabling public sharing the public link is timing out. 

Does anyone else report this problem ? Is there a problem on metabase side or why is this not working?



Hi @shad
Is the "Site URL" exactly the same as you're using to access Metabase with? Admin > Settings > General.

Hi Flamber,

Yes it is exactly the same

Should it be different?

Post "Diagnostic Info" from Admin > Troubleshooting.
And when you see an error, post the error from Admin > Troubleshooting > Logs.

"browser-info": {
"language": "en-US",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:88.0) Gecko/20100101 Firefox/88.0",
"vendor": ""
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.10+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "",
"java.version": "11.0.10",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.10+9",
"": "Linux",
"os.version": "4.14.209-160.339.amzn2.x86_64",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "11.5"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
"run-mode": "prod",
"version": {
"date": "2021-04-08",
"tag": "v0.38.4",
"branch": "release-x.38.x",
"hash": "057b6bb"
"settings": {
"report-timezone": "UTC"

There is no error appearing in the logs when the public link times out

@shad Okay, then post the log, so I can see there are requests for /public.
And check your browser developer Network-tab to see which server might be causing the timeout - the headers usually indicate that.

Hi Flamber,

I managed to solve the issue. I changed the site URL which was weird and it worked!!! Thank you for your help

@shad How can that be, when you said "Yes it is exactly the same" ?

Sorry I understood that the IP is the same as the public link one. But you meant between the IP and the non-public link, correct?

@shad No, I'm not talking about IP or hostname. I'm talking about "Site URL" in Admin > Settings > General, which has to be configured to exactly how you're accessing Metabase.
So if you access Metabase via, then the Site URL should be https://

Exactly, thank you! This has solved my issue. I changed it to the correct one

Thank you very much!