Public question doesn't show y axis via shared link or iframe on load

Hey!

I have the problem, that the y axis of charts (tried with bar and line chart) of public questions won’t show after loading with the public link or via iframe. After manually resizing the browser window the y axis will appear.
Tried on Chrome and Firefox.

Is this a bug or is there a url paramter to toggle the y axis?

Metabase version: 0.34.3

Public question via shared Link without y axis on load (after browser resize the y axis will appear)

Thank you!

That looks like a bug. This is my shared chart if anyone else wants to confirm: https://mail.pursuittechnology.co.uk:8443/public/question/5c5cc4b4-0790-4d0e-b57e-5a143f4ac1bf
Resizing makes the axis reappear. I couldn’t see anything on github, but I’m sure @flamber will be able to immediately point us to the issue! :smiley:

1 Like

Hi @basti
Yep, that’s a bug, but not one I ever remember seeing before, so I’ve created an issue:
https://github.com/metabase/metabase/issues/12018 - upvote by clicking :+1: on the first post.
A workaround is to enable “Show values on data points” (currently only available if it’s a single series)
Thanks @AndrewMBaines for the resize pointer!

3 Likes