Pulse Emails not stopping


Even though we have archived the pulses, we are still getting emails of pulses that were defined by us. The series of steps we followed in trying to stop the emails are as below -

  1. Archived the Pulses from Metabase UI
  2. Deleted metadata from metabase_oltp.pulse, metabase_oltp.pulse_card, metabase_oltp.pulse_channel & metabase_oltp.pulse_channel_receipent

Metabase Version - v0.39.0 & we are using Open Source Version

Kindly help on how to stop these emails from pulses.

Diagnostic Info -
"browser-info": {
"language": "en-IN",
"platform": "MacIntel",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.2 Safari/605.1.15",
"vendor": "Apple Computer, Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.17+8-post-Ubuntu-1ubuntu218.04",
"java.vendor": "Ubuntu",
"java.vendor.url": "https://ubuntu.com/",
"java.version": "11.0.17",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.17+8-post-Ubuntu-1ubuntu218.04",
"os.name": "Linux",
"os.version": "5.4.0-1057-aws",
"user.language": "en",
"user.timezone": "Etc/UTC"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MySQL",
"version": "5.7.38-log"
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.6.2"
"run-mode": "prod",
"version": {
"date": "2021-04-19",
"tag": "v0.39.0",
"branch": "release-x.39.x",
"hash": "5e40366"
"settings": {
"report-timezone": null

Hi @tarunkaneria
You are using heavily outdated version of Metabase. Please immediately upgrade for both security fixes and for the improved UI/functionality.

Pulses were deprecated and Metabase introduced dashboard subscriptions. This particular issue was solved one year ago in version 41.2

Have you tried searching our GitHub?

Hi @nemanja
Thanks for the response. Have gone through GitHub didn't find any particular solution with keeping the same version intact. If we upgrade to latest version now, will this problem be solved? Or it could be that we have multiple instance of Metabase installed & one of other instance is sending these mails?

The issue was resolved in 41.2 so you can try upgrading to that version first. The jump from 39 to the latest version is huge but you can try that as well.

Just please do not forget to backup your data before the upgrade. A lot has changed since 39 and the chance of something breaking for you is not insignificant.

Once upgraded, you shouldn't have this problem anymore.