Query Time out

One of my query was taking 60+ seconds. It was working fine on version 35.3 which was running on windows server. However, now I have moved to ubuntu and using 35.4 version. This query times out. Is it because of version change? or OS change? and how do I fix it. I am okay for it to run longer.

Hi @jiwnaiakbar
Could it be that you’re using a proxy/load-balancer on Ubuntu? You have to adjust the timeout of those, so it doesn’t close the connection.
Read more here:

Hi @flamber,

I am not using any load blanacer. Let me check if nginx timeout setting

@jiwnaiakbar Nginx has a default of 60 seconds, so unless you’ve changed that, then Nginx will close the connection (you can see that if you check the headers from the response in the browser developer console).

1 Like
 proxy_read_timeout 300;

added this in / location