RDS , EC2 Windows

Hello everyone,

I'm currently facing an issue while trying to establish a connection between my Metabase application, running on an EC2 instance (Windows Server), and a PostgreSQL RDS where my Metabase metadata is stored. Unfortunately, the connection attempts have been unsuccessful.

Here's an excerpt from the log of my RDS:

  • 2024-03-25 11:31:30 UTC:172.XX.X.XX(XXXXX):postgres@metabase:[29298]:FATAL: password authentication failed for user "postgres"
  • 2024-03-25 11:31:30 UTC:172.XX.X.XX(XXXXX):postgres@metabase:[29298]:DETAIL: Connection matched pg_hba.conf line 13: "host all all all md5"

Could anyone provide assistance with this issue? Any help would be greatly appreciated.

With a Windows client, I always find it easiest to just create an ODBC connection for test. Just helps find anything silly that you may have missed.

In your case - is the postgres user authorised to connect from that IP address?

1 Like

Hi @AndrewMBaines.
I tested in my machine the connection in a pgadmin and worked fine. The problem is in EC2 trying connection between the metabase application and the RDS.

I didn't think it was 'your' machine that was the problem. What about the connecting from EC2?

I Mean, when I try to establish a connection from my machine or from EC2 directly to a metabase.jar:

set MB_JETTY_PORT=4000
set MB_DB_TYPE=postgres
set MB_DB_DBNAME=metabase
set MB_DB_PORT=5432
set MB_DB_USER=postgres
set MB_DB_PASS=.......................YBarCk7D1^IO9V
set MB_DB_HOST=pentaho.cluster-c3su2yyislmf.us-east-1.rds.amazonaws.com
java -Xmx8g -jar metabase.jar

It retrieves something about the password. So I think when the process of
password encryption algorithm. Because it is very complex that password.

It worked. the encription was wrong.
so i changed the password.