Redirect to saved question using click behaviour

Hi,

I have a saved question (a table) from joining two tables from my database. I have also created a dashboard using data from that saved question. I want the user to click the bar on my barchart and be redirected to the saved question with the appropriate filters. However I dont wish to grant the user access to the table.
So is there any way i can redirect to that saved question without giving table access to the user?
Any help would be appreciated.

Thanks

Hi @PD98
I would recommend adding the question to another dashboard with the filters you want, and then set the Click Behavior to go to that dashboard.

Hi flamber,

I was actually looking for a drill-down kind of solution for this, where the appropriate filters automatically get passed on to the destination.
I tried your recommended method, but I am not able to see my column name for the second filter.

As depicted in the screenshot below, I can see the Status column to pass as filter for the first question.

But for the second question I cannot see my column name to pass to the destination. It only shows Count option.

@PD98 Post "Diagnostic Info" from Admin > Troubleshooting.
There are some known issues with the pass-thru, example this:
https://github.com/metabase/metabase/issues/15170
So without knowing which columns types the question has and which filter types are available, then it's difficult to know why that is happening.

Hi flamber,

I am attaching the Diagnostic info below

{
  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
    "java.vendor": "Ubuntu",
    "java.vendor.url": "https://ubuntu.com/",
    "java.version": "11.0.11",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9-Ubuntu-0ubuntu2.20.04",
    "os.name": "Linux",
    "os.version": "5.11.0-25-generic",
    "user.language": "en",
    "user.timezone": ""
  },
  "metabase-info": {
    "databases": [
      "mysql",
      "sqlserver"
    ],
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      },
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2021-07-14",
      "tag": "v1.40.1",
      "branch": "release-x.40.x",
      "hash": "ed8f9c8"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

Regarding the column types, the column type is of "category" and data type is boolean and the filter type is "category"

@PD98 If you are using the Enterprise Edition, then please use the support email, otherwise download the open source edition. Latest release is 0.40.5: https://github.com/metabase/metabase/releases/latest

There's something wrong with your Java timezone. Either it's being incorrectly set to "" or there's some problem with the system timezone not correctly defined.

You should migrate away from H2 if you're using Metabase in production:
https://www.metabase.com/docs/latest/operations-guide/migrating-from-h2.html

MySQL does not have a boolean data type. It is a TINYINT(1), which is then interpreted as a boolean. Seems like this actually might be a driver issue, but perhaps it is something that can be handled in the frontend.
I have created an issue for it:
https://github.com/metabase/metabase/issues/18067 - upvote by clicking :+1: on the first post

Hi flamber,

Thanks for creating the issue. I was actually facing this issue in SQL Server (MSSQL). Can you please add sql server in the labels or mention it in the description of the issue created in github.

Hi @flamber

I ran into another issue while testing click behavior. As I mentioned earlier, I did not provide table access to the user, but included that question in a dashboard.
I have granted "View Collection" permission to the user group, but the click behavior is not working.
When I log-in as the user with limited privileges, and click on a particular panel in the dashboard, nothing happens, even after configuring click behavior.

Would appreciate your help in this.

@PD98 You need to describe where the Click Behavior is going and the destination type.

@flamber yes I have configured click behavior of the panel to direct to a custom location and selected the appropriate dashboard, but it doesn't work when I am logging in as the user with limited privileges

@PD98 So you have created a Click Behavior with destination Dashboard? Does the user have access to that dashboard?

I cannot reproduce on 0.40.5. Please provide exact steps-to-reproduce.

@flamber Yes I created the click behavior with destination dashboard, and the user has view access to the entire collection in which both the source and destination dashboard reside.

  1. Create a table visualization from a database.
  2. Use this table visualization to create a few barcharts and add them to a dashboard.
  3. Add the table visualization to another dashboard within the same collection with appropriate filters.
  4. Create a click behavior for the dashboard containing the barcharts with destination dashboard set to the one containing the table question.
  5. Create a group which has no access to the database and only "view collection" access to the collection containing the above mentioned dashboards.
  6. Create a user and assign the above created group and login as that user and check if click behavior is working

@PD98 I cannot reproduce. If you can reproduce with Sample Dataset, then it'll be great and then you can create an issue with all the steps (including which questions and filters you are using, screenshots are helpful too) on Github: https://github.com/metabase/metabase/issues/new/choose
If you can only reproduce with a specific database or question types, then you'll need to describe that.

Hi @flamber ,

There is one thing I noticed while trying out click behavior.
When I configure the click behavior on a dashboard with no filter, it is able to redirect. But when I add a filter like a date filter it is not able to redirect.

I have kept the permissions same as mentioned in the previous message (user only has view collection permission and no permission on the database).

@PD98 Sounds like this:
https://github.com/metabase/metabase/issues/16201 - upvote by clicking :+1: on the first post