Redirection URL from alert not working

After trying to enter a metabase question, which I receive an alert email, I am faced with the following screen.


After receiving an email of metabase alert until 0.43.0 version, it was possible after click to redirect metabase question. Now after click this error appears.

Hi @Huseyn
Make sure your Site URL is correctly set in Admin > Settings > General.

@flamber,but it worked fine before updating to the latest version (0.43.0)

@Huseyn I'm guessing h8ml51j3tstzcumic8r is your host name and you're using Kubernetes?
If yes, then you're seeing this issue, which has a workaround in the comments: - upvote by clicking :+1: on the first post

@flamber thanks, I redirect your comment to our technical team, tomorrow I will feed back based on our team's answer. But I want to add we reverted the metabase to a previous version, but the issue persists. So we can say that this problem is not related to the metabase version.

@Huseyn Once the Site URL is changed, then it's changed. Go and manually change the Site URL.

@flamber FYI.

okay. Tomorrow we will try to do what you advise.

@flamber thank you very much. The problem solved!