Reverting to older Elastic Beanstalk Version breaks login


after upgrading to the latest v.47 we experienced some performance issues in loading times of dashboards and when working with mid-sized tables via the editor. Dashboard loading times went up from around 30sec to around 2 minutes. But the main issue is that while editing/building a question that uses a table with a bigger number (15+ or so) columns it takes about 4-5 seconds to add one new field in a filter, summarize, group by etc. It has not been like that in version prior to v.47

Due to that we wanted to revert to a previous version - we are using AWS Elastic Beanstalk. After deploying a prior version (I have tried multiple) all users are logged off and cannot log back in. Neither the Google SSO nor logging in via email&PW work. The login screen is shown but entering the credentials does not do anything.
However, re-reverting to v.47 works in terms of that we can log in again. Does anyone have an idea what might cause this and how I could revert to a functioning previous version?

Thank you!

We’re fixing the regression so you can upgrade to 47 without that problem, the issue you’re hitting is because you might have not restored a backup when moving back to 46

1 Like

Gotcha, thanks for the swift reply! Is there already any sort of timeline when the fix will be deployed?

@Luiggi we saw that the new version 47 is already available but until now not for AWS Elastic Beanstalk. Could you tell us when we can expect it? Thank you!

There’s not gonna be another beanstalk release as it was causing us many problems with customers. You can build your own bundle of beanstalk simply by changing the dockerrun file that’s inside the zip

Thanks for your answer!

Hi @Luiggi, we updated now to the newest metabase version (0.47.1 ) and the performance definitely improved. But it's still not as good as it was before we updated to version v047.0. Are you aware of something like this? Do also others report it?

The performance fixes will be in 47.2

1 Like