Run metabase as service on linux

How do I run metabase as service on linux?
NAME=“Oracle Linux Server”, VERSION=“7.8”
PRETTY_NAME=“Oracle Linux Server 7.8”

Hi @jiwnaiakbar
Have a look at the documentation. It’s written for Debian, but there’s very little difference between the distros, so it should be easy to make it work. As long as you’re using a distro that uses systemd:

Hi @flamber

I followed the steps and was able to follow through till end. However when I start the metabase.service, it fails. Log shows below error:
Error: Could not find or load main class metabase.core
any thoughts?

@jiwnaiakbar That sounds like an outdated version of Java - which version are you using?
java -version

Able to run it now. Error is slightly misleading. Issue is not with java version.

Issue was with user preveleges. some how the user prevelege for metabase user was not working. I used the root user to run the service and it worked. so that solves the problem. I will debug on where exactly the issue is with metabase user prevelege.