Save changes button in greyed out once making a changes in model

When I am making a changes in model (removing joins, adding new filters). Save changes button is greyed out.
My workaround is to go to Metadata tab and put fake description in column description area, then Save changes is avialable.
However bottom most view data still shows columns which I've for example removed from grouping - is it intendent behaviour?

I am using latest docker image.
Kind regards,

I experience the same issue: adding joins or filters does not enable the 'save changes' button.

The bottom pane still shows columns I've put on 'Do not include' in the Data Model in the Admin Settings:

And these columns are not visible in the drop down box above:

The workaround suggested by Piotr works: if I change something in the metadata tab, I can save my model:


But even after that, the old columns still show in the tabular data:

Is this a caching problem? These columns used to be in there, I only recently did a cleanup. Is it still showing some older version of my model?