Saved questions not showing as data source

Hello, I have been using metabase for almost 2 weeks with great results for my team.

Today we faced the requirement to use nested queries, after some googling found out that is a feature and that we have it enabled on the settings page.

Been poking around but haven’t be able to even see one of my saved questions as data source on simple and custom questions.

Tried to find out some documentation about it without success. If there is anything that I should check specifically please let me know so I can enable this amazing feature on our system.

Some details:

Running metabase 0.34.3 over docker, connected postgres, firebird and h2 databases (saved questions doesn’t show for any of them). Tried with really simple questions without success

Thanks for your time!

“browser-info”: {
“language”: “en-US”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36 Edg/80.0.361.69”,
“vendor”: “Google Inc.”
“system-info”: {
“”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.5+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “”,
“java.version”: “11.0.5”,
“”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.5+10”,
“”: “Linux”,
“os.version”: “4.19.98-Unraid”,
“user.language”: “en”,
“user.timezone”: “America/Mexico_City”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “postgres”,
“application-database-details”: {
“database”: {
“name”: “PostgreSQL”,
“version”: “12.2 (Debian 12.2-2.pgdg100+1)”
“jdbc-driver”: {
“name”: “PostgreSQL JDBC Driver”,
“version”: “42.2.8”
“run-mode”: “prod”,
“version”: {
“date”: “2020-02-25”,
“tag”: “v0.34.3”,
“branch”: “release-0.34.x”,
“hash”: “1a83edb”
“settings”: {
“report-timezone”: “America/Mexico_City”

Hi @dealanis
There are a couple of limitations with Saved Questions:
And then there is a visual bug, where you might need to refresh the browser after saving a new question before you can see it in Saved Questions.

Thanks for your quick reply!

It finally showed! I was refreshing and restarting the container without success. The steps that worked for me were refreshing on the “pick your data” screen precisely for the saved questions to show.

Thank you again!