Schemas are empty

I’m trying to set up Metabase to query my MongoDB.
The database seems linked as it appears un /admin/databases.
The tables seems to be well retrieved as they appear in /admin/datamodel/…

But no schema is found for every table. There is no columns displayed.

My database is hosted at mongolab.
DB size is around 22GB.
Mongo version is 3.0.10
It is highly possible than all the rows of the tables does not follow the exact same schema.
Metabase app is hosted on heroku but still no schemas when i tried the Mac app.
I can’t get no more informations.

Any idea about what is happening?


Can you give us some example documents? Also, can you copy+paste the logs that are generated when you run a manual sync under /admin/databases/? You can get those from the heroku logs or on the mac app via the “Console” application.

With the metabase console i got this logs while syncing my Database:

03-17 19:59:06 DEBUG metabase.middleware :: POST /api/database/2/sync 200 (5 ms)
03-17 19:59:06 DEBUG db.internal :: DB CALL: User [:id :email :date_joined :first_name :last_name :last_login :is_superuser :is_qbnewb :is_active :is_staff] (where (limit (select* ENTITY24489) 1) {:id current-user-id})
03-17 19:59:06 DEBUG db.internal :: DB CALL: Database * (where (limit (select* ENTITY29138) 1) {:id (events/object->model-id topic object)})
03-17 19:59:06 DEBUG mongo.util :: << OPENED NEW MONGODB CONNECTION >>
03-17 19:59:06 INFO driver.sync :: Syncing MongoDB database 'Preprod'...
03-17 19:59:16 ERROR events.sync-database :: Error syncing Database: 2 #error {
 :cause nil
 [{:type java.lang.NullPointerException
   :message nil
   :at nil}]

Something is null and not handled

Thanks for the help :wink:

Sounds like a bug.

Mind opening an issue at ? That way when it’s worked on, you’ll be notified, and it’ll be easier to get all the info together in a single place.