Setting kubernetes cluster single replica on google cloud results in frequent restarts

I'm referring to as that was on the official filter;

I am trying set metabase CE on k8 cluster (1 replica only); See metabase-config.yaml below for info;
I do:

helm repo add one-acre-fund
helm install my-release one-acre-fund/metabase

and get

NAME                                       READY   STATUS    RESTARTS   AGE
pod/my-release-metabase-7479bfc65d-nv985   0/1     Running   6          11m
pod/my-release-postgresql-0                1/1     Running   0          11m

NAME                                  READY   UP-TO-DATE   AVAILABLE   AGE
deployment.apps/my-release-metabase   0/1     1            0           11m

NAME                                     TYPE        CLUSTER-IP       EXTERNAL-IP   PORT(S)    AGE
service/kubernetes                       ClusterIP     <none>        443/TCP    169m
service/my-release-metabase              ClusterIP   <none>        3000/TCP   11m
service/my-release-postgresql            ClusterIP    <none>        5432/TCP   11m
service/my-release-postgresql-headless   ClusterIP   None             <none>        5432/TCP   11m

Clearly this isn't working;

kubectl logs pod/my-release-metabase-7479bfc65d-nv985
Warning: environ value jdk-11.0.12+7 for key :java-version has been overwritten with 11.0.12
WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
2021-09-16 17:04:58,777 INFO metabase.util :: Maximum memory available to JVM: 494.9 MB
2021-09-16 17:05:39,560 INFO util.encryption :: Saved credentials encryption is DISABLED for this Metabase instance. 🔓
 For more information, see

Any resolution would /guidance would be helpful;
more logs

kubectl describe pod/my-release-metabase-7479bfc65d-nv985

Name:         my-release-metabase-7479bfc65d-nv985
Namespace:    default
Priority:     0
Status:       Running
Controlled By:  ReplicaSet/my-release-metabase-7479bfc65d
Init Containers:
    Image:         jwilder/dockerize:0.6.1
    Image ID:
    Port:          <none>
    Host Port:     <none>
    State:          Terminated
      Reason:       Completed
      Exit Code:    0
      Started:      Thu, 16 Sep 2021 16:51:53 +0000
      Finished:     Thu, 16 Sep 2021 16:51:53 +0000
    Ready:          True
    Restart Count:  0
      cpu:                500m
      ephemeral-storage:  1Gi
      memory:             2Gi
      cpu:                500m
      ephemeral-storage:  1Gi
      memory:             2Gi
    Environment:          <none>
      /var/run/secrets/ from kube-api-access-6gg86 (ro)
    Image:          metabase/metabase:latest
    Image ID:
    Port:           3000/TCP
    Host Port:      0/TCP
    State:          Running
      Started:      Thu, 16 Sep 2021 17:12:36 +0000
    Last State:     Terminated
      Reason:       Error
      Exit Code:    143
      Started:      Thu, 16 Sep 2021 17:11:14 +0000
      Finished:     Thu, 16 Sep 2021 17:12:35 +0000
    Ready:          False
    Restart Count:  9
      cpu:                500m
      ephemeral-storage:  1Gi
      memory:             2Gi
      cpu:                500m
      ephemeral-storage:  1Gi
      memory:             2Gi
    Liveness:             http-get http://:3000/api/health delay=60s timeout=1s period=5s #success=1 #failure=5
    Readiness:            http-get http://:3000/api/health delay=10s timeout=1s period=5s #success=1 #failure=15
      MB_DB_TYPE:    postgres
      MB_DB_DBNAME:  metabase
      MB_DB_PORT:    5432
      MB_DB_USER:    metabase
      MB_DB_PASS:    <set to the key 'db-password' in secret 'my-release-metabase'>  Optional: false
      MB_DB_HOST:    my-release-postgresql.default.svc
      /plugins from plugin-volume (rw)
      /var/run/secrets/ from kube-api-access-6gg86 (ro)
  Type              Status
  Initialized       True 
  Ready             False 
  ContainersReady   False 
  PodScheduled      True 
    Type:       EmptyDir (a temporary directory that shares a pod's lifetime)
    SizeLimit:  <unset>
    Type:                    Projected (a volume that contains injected data from multiple sources)
    TokenExpirationSeconds:  3607
    ConfigMapName:           kube-root-ca.crt
    ConfigMapOptional:       <nil>
    DownwardAPI:             true
QoS Class:                   Guaranteed
Node-Selectors:              <none>
Tolerations:        op=Exists for 300s
                    op=Exists for 300s
  Type     Reason            Age                   From                                   Message
  ----     ------            ----                  ----                                   -------
  Normal   TriggeredScaleUp  22m                   cluster-autoscaler                     pod triggered scale-up: [{ 1->2 (max: 1000)}]
  Warning  FailedScheduling  22m (x4 over 22m)  0/2 nodes are available: 1 Insufficient memory, 2 Insufficient cpu.
  Warning  FailedScheduling  21m (x2 over 21m)  0/3 nodes are available: 1 node(s) had taint { }, that the pod didn't tolerate, 2 Insufficient cpu, 2 Insufficient memory.
  Normal   Scheduled         21m           Successfully assigned default/my-release-metabase-7479bfc65d-nv985 to gk3-metabase-default-pool-a14ac9f4-rv8v
  Normal   Pulling           21m                   kubelet                                Pulling image "jwilder/dockerize:0.6.1"
  Normal   Pulled            20m                   kubelet                                Successfully pulled image "jwilder/dockerize:0.6.1" in 7.594228043s
  Normal   Pulling           20m                   kubelet                                Pulling image "metabase/metabase:latest"
  Normal   Created           20m                   kubelet                                Created container wait-db
  Normal   Started           20m                   kubelet                                Started container wait-db
  Normal   Pulled            20m                   kubelet                                Successfully pulled image "metabase/metabase:latest" in 8.892920689s
  Normal   Created           20m                   kubelet                                Created container app
  Normal   Started           20m                   kubelet                                Started container app
  Warning  Unhealthy         11m (x31 over 19m)    kubelet                                Liveness probe failed: Get "": dial tcp connect: connection refused
  Warning  BackOff           5m52s (x20 over 10m)  kubelet                                Back-off restarting failed container
  Warning  Unhealthy         57s (x125 over 20m)   kubelet                                Readiness probe failed: Get "": dial tcp connect: connection refused


# Currently Metabase is not horizontly scalable. See
# and
# NOTE: Should remain 1
replicaCount: 1
podAnnotations: {}
podLabels: {}
  repository: metabase/metabase
  tag: latest
  pullPolicy: IfNotPresent
  replicas: 1

## String to fully override metabase.fullname template
# fullnameOverride:

# Config Jetty web server
  host: ""
  port: 3000
  # If you have an ssl certificate and would prefer to have Metabase run over HTTPS
  enabled: true
  # port: 8443
  # keyStore: |-
  #   << JKS KEY STORE >>
  # keyStorePassword: storepass
#  maxThreads: 254
#  minThreads: 8
#  maxQueued: -1
#  maxIdleTime: 60000

# Backend database
  # Database type (h2 / mysql / postgres), default: h2
  type: postgres
  # encryptionKey: << YOUR ENCRYPTION KEY >>
  ## Only need when you use mysql / postgres
  # host:
  # port:
  # dbname:
  # username:
  # password:
  ## Alternatively, use a connection URI for full configurability. Example for SSL enabled Postgres.
  # connectionURI: postgres://user:password@host:port/database?ssl=true&sslmode=require&sslfactory=org.postgresql.ssl.NonValidatingFactory"
  connectionURI: "postgres://metabase:ciJ8KfiMUK@localhost:5432/metabase?ssl=true&sslmode=require&sslfactory=org.postgresql.ssl.NonValidatingFactory"
  ## If a secret with the database credentials already exists, use the following values:
  # existingSecret:
  # existingSecretUsernameKey:
  # existingSecretPasswordKey:
  # existingSecretConnectionURIKey:

  # Changing Metabase password complexity:
  # weak: no character constraints
  # normal: at least 1 digit (default)
  # strong: minimum 8 characters w/ 2 lowercase, 2 uppercase, 1 digit, and 1 special character
  complexity: normal
  length: 6

timeZone: UTC
emojiLogging: true
# javaOpts:
# pluginsDirectory:
# siteUrl:

session: {}
  # maxSessionAge:
  # sessionCookies:

  initialDelaySeconds: 120
  timeoutSeconds: 30
  failureThreshold: 6

  initialDelaySeconds: 30
  timeoutSeconds: 3
  periodSeconds: 5

  name: metabase
  type: ClusterIP
  externalPort: 80
  internalPort: 3000
  # Used to fix NodePort when service.type: NodePort.
  annotations: {}
    # Used to add custom annotations to the Service.
    # ""
  enabled: false
  # Used to create Ingress record (should used with service.type: ClusterIP).
    # -
  # The ingress path. Useful to host metabase on a subpath, such as `/metabase`.
  path: /
    # Used to add custom labels to the Ingress
    # Useful if for example you have multiple Ingress controllers and want your Ingress controllers to bind to specific Ingresses
    # traffic: internal
  annotations: {}
    # nginx
    # "true"
    # Secrets must be manually created in the namespace.
    # - secretName: metabase-tls
    #   hosts:
    #     -

# A custom file can be provided using a multiline YAML string.
# See
# log4jProperties:

resources: {}
  # We usually recommend not to specify default resources and to leave this as a conscious
  # choice for the user. This also increases chances charts run on environments with little
  # resources, such as Minikube. If you do want to specify resources, uncomment the following
  # lines, adjust them as necessary, and remove the curly braces after 'resources:'.
  # limits:
  #  cpu: 100m
  #  memory: 128Mi
  # requests:
  #  cpu: 100m
  #  memory: 128Mi

## Node labels for pod assignment
## ref:
nodeSelector: {}

## Tolerations for pod assignment
## ref:
tolerations: []

## Affinity for pod assignment
## ref:
affinity: {}

is it a memory allocation issue or something else? And
Is this still relevant:

Hi @codecakes
500MB memory is too little. You should be seeing OOM-killer messages, but perhaps those are swallowed, when it restarts the pod.
My first guess is that you are giving very few resources. Otherwise you might be running out of entropy.
Metabase should start in about 35 seconds.

Will update here after raising the cap;