Settings ingress for values.yaml

Hi everyone,

im trying to deploy metabase on EKS,
Anyway, i've got a problem for the settings in the values.yaml

[ec2-user@ip-10-25-64-25 Metabase]$  helm install metabase-a0000125955 metabase-chart-a0000125955-0.1.0.tgz
WARNING: Kubernetes configuration file is group-readable. This is insecure. Location: /home/ec2-user/.kube/config
WARNING: Kubernetes configuration file is world-readable. This is insecure. Location: /home/ec2-user/.kube/config
Error: INSTALLATION FAILED: Ingress.extensions "metabase-a0000125955-metabase-chart-a0000125955" is invalid: spec.rules[0].host: Invalid value: "metabase_a0000125955.local": a lowercase RFC 1123 subdomain must consist of lower case alphanumeric characters, '-' or '.', and must start and end with an alphanumeric character (e.g. '', regex used for validation is '[a-z0-9]([-a-z0-9]*[a-z0-9])?(\.[a-z0-9]([-a-z0-9]*[a-z0-9])?)*')
[ec2-user@ip-10-25-64-25 Metabase]$```

Can anyone help with the settings for the ingress in values.yaml?

Hi @aresb
Post your configuration or link.
It says it doesn't allow underscore in the name of host.

1 Like