Slack Integration - Help


I am using the version of metabase 0.32.10 when I do the integration with slack I am able to see metabase bot and request list of reports. When I request a specific report I get an error that the channel is missing.

As you can see from the image below the channel is present, the bot is invited. Has anyone had this issue before? Should I change channel name to just an ID?

Hi @mundurraga
I don’t have Slack, but have you tried removing the integration and adding it again. Everything looks correct, but maybe it’s something under the hood.
EDIT: If you check the Metabase log, do you see any errors about Slack that could help troubleshooting?

@flamber Hello, yes I did remove and add again. Its working as you can see, it replies and shows list of reports… it just has an issue with the channel. I dont see any errors on the log for troubleshooting…
Thank you.

Since my lack of knowledge about Slack, but I would guess it has something to do with the MetaBot user doesn’t have rights/permissions to the channel.
With the amount of people using Metabase with Slack, if something was wrong, then there would have been many reports, but it’s the first time I see this.
Is there something special about your Slack setup - or is the metabase_files channel set to private?

I understand, it was my conclusion too, that if something was wrong I would see several people complaint. I wasnt able to find any issue on slack integration.

The channel is public and metabot has permissions to publish. I will try to check security or reinstall everything again.

Aug 22 08:06:34 ERROR metabase.integrations.slack :: Slack channel named metabase_files is missing! Please create the channel in order to complete the Slack integration. The channel is used for storing graphs that are included in pulses and MetaBot answers.

Aug 22 08:06:34 ERROR metabase.metabot.slack :: Error in Metabot command

clojure.lang.ExceptionInfo: Slack channel named metabase_files is missing! Please create the channel in order to complete the Slack integration. The channel is used for storing graphs that are included in pulses and MetaBot answers. {:status-code 400}

at metabase.integrations.slack$files_channel_STAR_.invokeStatic(slack.clj:78)

at metabase.integrations.slack$files_channel_STAR_.invoke(slack.clj:75)

at clojure.lang.AFn.applyToHelper(

at clojure.lang.AFn.applyTo(

at clojure.core$apply.invokeStatic(core.clj:665)

at clojure.core$apply.invoke(core.clj:660)

at clojure.core.memoize$through_STAR_$fn__2956.invoke(memoize.clj:104)

at clojure.core.cache$through$fn__2680.invoke(cache.clj:55)

at clojure.core.memoize$through_STAR_$fn__2952$fn__2953.invoke(memoize.clj:103)

at clojure.core.memoize.RetryingDelay.deref(memoize.clj:66)

at clojure.core$deref.invokeStatic(core.clj:2320)

at clojure.core$deref.invoke(core.clj:2306)

at clojure.core.memoize$build_memoizer$fn__3037.doInvoke(memoize.clj:210)

at clojure.lang.RestFn.invoke(

at clojure.lang.AFn.applyToHelper(

at clojure.lang.RestFn.applyTo(

at clojure.lang.AFunction$1.doInvoke(

at clojure.lang.RestFn.invoke(

at metabase.pulse$create_slack_attachment_data.invokeStatic(pulse.clj:69)

at metabase.pulse$create_slack_attachment_data.invoke(pulse.clj:66)

at metabase.metabot.command$fn__50758$fn__50762.invoke(command.clj:177)

at metabase.metabot.slack$do_async$fn__50696$fn__50697.invoke(slack.clj:42)

at metabase.metabot.slack$do_async$fn__50696.invoke(slack.clj:41)

at clojure.core$binding_conveyor_fn$fn__5754.invoke(core.clj:2030)


at java.base/

at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(

at java.base/java.util.concurrent.ThreadPoolExecutor$

at java.base/

@flamber hello, does this help?


Is there something special about your Slack setup?
Or is the metabase_files channel set to private? MetaBot doesn’t work with private channels.

When you tried to “reinstall” the integration, did you remove everything Metabase related in Slack - including metabase_files channel?

No we did not, but our slack setup has a lot of channels over 2k maybe the issue is when it list all channels and tries to parse…

We do not have it private nor did we remove anything.

It could be something to with the amount of channels, but then I would have expected some type of error (or out-of-memory).
You said in comment 5: “reinstall everything again”, then I thought that you removed the Slack integration (and removed MetaBot user and metabase_files channel) and tried to set it up again.
Well, otherwise I would recommend that you open a new issue - provide as many details as possible (and link to this thread too).
And please post the issue link here for reference :+1: