Smart Number - Group by time field error

Hello, I’m trying to use the Smart Number visualization in v0.32.8 and I get the error “Group by a time field to see how this has changed over time”.

Any advice?

Thanks!

Scott

Here’s the raw data in a table visualization:

Scott

Hi @smccandl
Can you try removing the sorting, just to see if that is triggering something?
Which database are you querying?
I’ve tried to reproduce your issue with the Sample Dataset without success, so I’m not sure what the problem might be.

@flamber, thanks. Sample dataset also works fine for me. Target DB is sqlite.

edit: Removing the sorting didn’t help.

Scott

@smccandl
I’m trying to reproduce your issue with Chinook sample data, but without success. Not sure if it might have something to do with Field Type, which you set in Admin Settings > Data Model > (database) > (table) > (column) :gear:
What’s the actual database column type of End Time?
The column type of InvoiceDate is DATETIME and the field type is No special type.


End Time has type “text” – changing it to datetime did fix the problem. Thanks!

The sqlite datatypes page says: “SQLite does not have a storage class set aside for storing dates and/or times.”, but it does later reference datetime, so, learned something new today.

Thanks again @flamber

Scott

1 Like