Snowflake Connection

Hi, I’m trying to connect to Snowflake with Metabase. I believe that all of my connection information is entered correctly, but when I click save on the database connection it gives the “Timed out after 5,000 milliseconds” error. I’m using version 0.32.8 of Metabase.

Hi @jacobr
Can you try with the latest release 0.32.9, since there were some bad drivers in 0.32.8 I think.
Normally the timeout error occurs, when address/port is incorrect or blocked by firewall.

I was able to connect by removing the region and the url suffix from the account section. I am now running into an issue where I have created a user in snowflake that only has select access, and I am not able to connect with that user. If I grant that user all privileges then I am able to connect, but we only want this user to be able to read. We don’t want the user to be able to create or delete or drop. Does anyone know a way to create the connection with a read only user?

Thanks so much for your help!

@jacobr
I think you’re seeing this issue about the region:
https://github.com/metabase/metabase/issues/10142
I’m not totally sure how the Snowflake driver is, but many of the other drivers requires it to set some options (usually timezone stuff), which is usually not allowed for read-only users.
But most of the drivers does not allow to send insert, update, delete commands - again, haven’t checked the Snowflake driver.

That makes sense. I’m happy to hear that most drivers will block those DDL commands. Is there any way to see if the snowflake driver does block those? Would I just need to clone the repo and search for it in the code?

@jacobr The Snowflake driver is located here:
https://github.com/metabase/metabase/tree/master/modules/drivers/snowflake

Thanks for linking this! You’ve been extremely helpful!