[SOLVED] 0.31 variables not working

Field filter are broken.

On existing or new questions this is what is displayed. The selection window is missing.

the error on chrome console when trying to expand the “field map to” menu

app-main.bundle.js?78e15b587bf48274efb7:5 Uncaught TypeError: Cannot read property ‘name’ of undefined
at t.TablePicker (app-main.bundle.js?78e15b587bf48274efb7:5)
at u._constructComponentWithoutOwner (vendor.bundle.js?78e15b587bf48274efb7:145)
at u._constructComponent (vendor.bundle.js?78e15b587bf48274efb7:145)
at u.mountComponent (vendor.bundle.js?78e15b587bf48274efb7:145)
at Object.mountComponent (vendor.bundle.js?78e15b587bf48274efb7:83)
at J.mountChildren (vendor.bundle.js?78e15b587bf48274efb7:145)
at J._createInitialChildren (vendor.bundle.js?78e15b587bf48274efb7:145)
at J.mountComponent (vendor.bundle.js?78e15b587bf48274efb7:145)
at Object.mountComponent (vendor.bundle.js?78e15b587bf48274efb7:83)
at u.performInitialMount (vendor.bundle.js?78e15b587bf48274efb7:145)

I can’t reproduce this in 0.31 with Chrome or Safari on macOS. What browser and OS are you using?

Hi maz,

i’ve tried with chrome, firefox ,chrome on linux. Same behavior, all of them.

At the end I’ve restored a older backup of the VM just right after updating to .31 and the filters are working again.

i guess the something has been corrupted on the db (im using mysql). Dont know. i’ll keep this thread updated in case the the issue is back.

Same issue again :frowning:

i think i found the issue.

I’ve configured the “This is a large database, so let me choose when Metabase syncs and scans” to scan the DB only during night hours.

For some reason this cause the abode error.

Now is back to hourly scan and field map filter is working again.