[SOLVED] Can't get values shown in custom regional map

Hullo. :slight_smile:

Using metabase version 0.32.5, I imported a custom regional map of southern California zip codes using this geojson file: http://s3-us-west-2.amazonaws.com/boundaries.latimes.com/archive/1.0/boundary-set/zip-code-tabulation-areas-2012.geojson

And metabase seems happy with it:

But when I try to use the results from this table (showing in text instead of a picture because I’m only allowed one to post one picture, because ima noob:
Columns: Event Count, Zip, Geom, Longitude, Latitude
Example row: 3167, 90095, 0101000020E6100000000000A0629C5DC0000000201D094140, -118.44, 34.07

As a regional map (selecting that custom map with “Event Count” as the Metric Field and “Zip” as the Region Field) nothing is colored in.

I did confirm that zipcode 90095 exists in the geojson file, as an external ID.

I do see this in the metabase server logs:

04-24 19:33:09 DEBUG middleware.log :: POST /api/dataset 200 [ASYNC: completed] 9 s (9 DB calls) Jetty threads: 8/50 (2 busy, 5 idle, 0 queued) (50 total active threads)
04-24 19:33:09 WARN middleware.async :: Unhandled exception, exepected catch-exceptions middleware to handle it.
java.lang.Exception: Invalid response from database driver. No :status provided.true
at metabase.query_processor.middleware.process_userland_query$format_userland_query_result.invokeStatic(process_userland_query.clj:97)
at metabase.query_processor.middleware.process_userland_query$format_userland_query_result.invoke(process_userland_query.clj:87)
at clojure.core$partial$fn__5828.invoke(core.clj:2638)
at metabase.query_processor.middleware.async_wait$wait_for_permit$fn__33563$fn__33602$state_machine__8574__auto____33623$fn__33625.invoke(async_wait.clj:49)
at metabase.query_processor.middleware.async_wait$wait_for_permit$fn__33563$fn__33602$state_machine__8574__auto____33623.invoke(async_wait.clj:49)
at clojure.core.async.impl.ioc_macros$run_state_machine.invokeStatic(ioc_macros.clj:973)
at clojure.core.async.impl.ioc_macros$run_state_machine.invoke(ioc_macros.clj:972)
at clojure.core.async.impl.ioc_macros$run_state_machine_wrapped.invokeStatic(ioc_macros.clj:977)
at clojure.core.async.impl.ioc_macros$run_state_machine_wrapped.invoke(ioc_macros.clj:975)
at clojure.core.async.impl.ioc_macros$take_BANG_$fn__8592.invoke(ioc_macros.clj:986)
at clojure.core.async.impl.channels.ManyToManyChannel$fn__3478$fn__3479.invoke(channels.clj:95)
at clojure.lang.AFn.run(AFn.java:22)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

But based on this issue: https://github.com/metabase/metabase/issues/9818 I don’t think it’s related.

Hi @tflecht
I’ve just tried adding the map and running a query using Sample Dataset and I’m getting a map:


Can you make a test with the sample data or attach a file with results, so I can try to reproduce the issue?
The log error, does it match the time, when you’re having map problems? Otherwise it might just be an unrelated issue, which likely is the issue you linked to.
Do you see any errors in the browser console?

Hi @flamber, tyvm for your help! I can also run the query you provided using the sample dataset, and i also get the map showing those results.

I’m on OSX 10.14.4 (Mojave), using Chrome by the way.

I don’t see any Chrome console errors when I run your query. When I run mine, I get these:


When I present the results of my query in table form instead of map, I don’t see those errors in my Chrome console.

The error in the log I mentioned does correlate in time with my attempts to view the map, but I also get it when I successfully run your query.

I’m not sure what results I should attach in a file… the query results?

Here are some of the rows resulting from my query; its the same query shown in the screen shot above:

Okay, I’ve converted your image to data with OCR and then I did a another test, but I’m still getting data - the only problem is that the zip-codes seems to be really small on that map, so it’s almost impossible to see, since the map doesn’t automatically zoom-to-content.

I’m pretty sure the zoom-to-content is this issue - go and upvote by clicking :+1:

Or maybe use a small map, if you’re only using zip-codes 90000-90999, then you’ll see something like this:

Oh sheesh, that’s what’s happening. Thank you very much @flamber.