SOLVED-Can't install local Metabase on mac from scratch

I forgot my credentials on my local Metabase on MAC so I decided to reinstall it.

  1. I uninstalled Metabase app
  2. Removed all files and folders with ‘metabase’ in their name in /Library
  3. I checked if there are any other files called metabase anywhere (there aren’t)
  4. Emptied trash
  5. restarted laptop

Then I tried to install metabase again but instead of setup screen, login screen appear so I can’t get in.

Did anyone have same/similar problem?

Hi @Nikki
The internal metadata database is normally stored in ~/Library/Application Support/Metabase/
Can you double check that it’s been removed?
EDIT: And you have to close Metabase before removing metadata, since it might lock file connection otherwise.

Hi @flamber,

Thank you for quick response. There is no metabase folder in my /Library/Application Support and I can’t find any or metabase.db.h2.db on my machine.

It’s possible that I removed that db while Metabase was open, is it possible that it got “stuck”?

Hi @Nikki
It’s not /Library/..., it’s ~/Library/..., which is your home directory - translated fully it becomes /Users/Nikki/Library/Application Support/Metabase/

:face_with_hand_over_mouth: you’re right, this was the problem.
Thank you so much!

1 Like