[SOLVED] Restarted computer and nothing works now?! (DB connection limit)

So I had set a nice dashboard with about 30 graphs that worked beautifully.

I had to check it from the web since the desktop app seems to have problems supporting > 10 graphs. So I copied the url from the top right thumbnail and pasted it into the browser bar.

Now I restarted the computer and it seems that Metabase fails to do any db query. The db hasn’t changed nor it’s params. I’m also using SQLPro to access the db without issues, same credentials etc.

How can I debug what exactly is going wrong on the Metabase side? It seems to be able to find the tables but all the graphs return a “There is a problem displaying this chart”, and individual queries return “Connections could not be acquired from the underlying database!” Again, from sqlpro there’s no issue and I’m using the same credentials + data there, and also it worked before restart.

I have also checked the config and the relevant db info is still there and correct.

Btw, is there a way for metabase to always use the same local port? I need to get the url every time just because of that…

Thank you!

Which version of Metabase are you on? We had some lockups caused by heavily concurrent workloads (such as loading a dashboard with a lot of cards) that were fixed in 0.30.2

Thanks Simon, I’m was indeed on 0.30.1. However, for anyone stumbling upon this thread, I found the problem to be that I had reached the max connections to the RDS DB and metabase was being unable to connect. Seeing a more detailed error would have helped a bunch but yeah, it wasn’t metabase’s fault but mine ;D cheers!