[SOLVED] Show values on data points

Hi guys!!
I need a little help over here.
I love the Metabase and I’m a beginner in it.
So, I have a lot of graphics and lines of data, but I need to show the value of my data in each point of my graphs.

I read the document and I found there something that tell about it, but don’t explain how that I do.
There it is:
“Show values on data points. The default setting will try and fit as many values on your chart as will fit nicely, but you can also force Metabase to show the values for each and every data point, which it will do begrudgingly.”

To exemple what I’m talking about, where is the red mark is the data of the each point of information that I need to show up

Can you guys could please, please help me??
Thank you a lot!

Hi @puglisi
Are you using version 0.34.0?
I’m a little confused. Are you asking where to enable data points?
Click the visualization Settings > Display > activate “Show values on data points” in the bottom and click “All”.

1 Like

Yes, is it what I need, but this option doesn’t show to me.
Is it any configuration that I have to do before?


Thank you very much!!

@puglisi Which version are you using? Post “Diagnostic Info” from Admin > Troubleshooting.

1 Like

It is that?

  "browser-info": {
    "language": "pt-BR",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "java.runtime.name": "Java(TM) SE Runtime Environment",
    "java.runtime.version": "1.8.0_231-b11",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_231",
    "java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
    "java.vm.version": "25.231-b11",
    "os.name": "Windows 10",
    "os.version": "10.0",
    "user.language": "pt",
    "user.timezone": "GMT-03:00"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "h2",
    "run-mode": "prod",
    "version": {
      "tag": "v0.34.0",
      "date": "2019-12-19",
      "branch": "release-0.34.x",
      "hash": "1335215"
    "settings": {
      "report-timezone": "America/Sao_Paulo"

@puglisi Ahhh, now I noticed it. You’re using a Combo visualization, if you change it to Line or Bar, then you have the option available.
Currently the data points/values are only available on single series, non-stacked.
Upvote the following issues by clicking :+1: on the first post of each:



Thank you so much!!!

1 Like

@puglisi Great that we could find the cause of this :+1:
I can see that some of the strings have not been translated in Portuguese, so if you want to help out with that, then visit https://poeditor.com/join/project/ynjQmwSsGh

1 Like

@flamber Oh it’s great!
I will help for sure. Thank you for the tip! :smiling_face_with_three_hearts:

1 Like

Thanks you guys, you’ve helped me also.

1 Like


My metabase do not show these options, and I’m using a Bar type… You guys know if is it occuring because my question was written in SQL?

@camilamorais, this feature currently is limited to charts with a single series. The option isn’t showing up because you have 3 series: OTHERS, SPOT, and SUBSCRIBER. The option will show up if you only have one of those three. We plan on improving this feature soon to enable it to work with multiple series.


Hey guys!
I exactly have the same problem but the solution you provided doesn’t work for me, even though I am plotting a simple line graph.
Anybody can help me with it?
Thanks in advance!

@elysee Which version of Metabase?

Oh,I am using v0.33.0
Sorry I missed the part that version might be the problem How to overcome that? Only available with v0.34?


@elysee Yes, it’s only available since 0.34.0 - I would recommend that you upgrade at some point to the latest release (currently 0.34.3), just remember to backup before in case something goes wrong or if you quickly want to revert.

Alrighty. Thank you very much for your support @flamber!:boom: