Some mongo collections not showing up

I have connected to a Mongo 3.2 instance. I can see the schema of some collections and not for others.
What goes ? I am using Metabase on a Mac

For example here is a schema I can see (screenshots from Metabase and MongoChef)

And here is a schema I cannot see

Hi. Since Mongo is a schemaless document database Metabase attempts to inspect some of your data and build a schema for the collection based on what it sees. Since you collection is not showing up with any fields in it I’m guessing that we’ve run into some kind of error.

Can you access the application logs when you try to add your Mongo database and pull out any errors you see? That will help us troubleshoot this.

I tried this after installing metabase on a EC2 server. Issue seems to have resolved itself

good to hear. it’s possible that if you were looking immediately after adding the database we just hadn’t had enough time to introspect the collections and build up the metadata yet.

Am facing this issue now. Metabase refuses to import a specific collection, while all other collections are being imported fine.

Any advice on how to solve this?

@adikhel You should probably have started a new topic instead of replying to a 4 year old topic.
Which version of Metabase?
Are you using MongoDB Atlas?
Do you see any errors in the log (Admin > Troubleshooting > Logs), when doing a forced sync/scan (Admin > Databases > your-db)?

Whoops. Will keep that in mind.

Figured out the issue. The collection was being flagged as ‘hidden’. Changing it to ‘queryable’ in the db schema fixed it.