SSL on Windows (443 already in use) [SOLVED]

I’m running Metabase on a server that’s also running various websites on IIS.
I’ve configured all the SSL settings including the certificate. I’ve set MB_Jetty_Port=8443
When I start Metabase, I get the following in the logs:

08-16 16:20:13 ←[1mINFO metabase.core←[0m :: Launching Embedded Jetty Webserver with config:
 {:port 8443, :host "10.0.0.8", :ssl? true, :keystore "c:\\metabase\\alerts.jks"}
08-16 16:20:13 ←[1mWARN component.AbstractLifeCycle←[0m :: FAILED ServerConnector@33f1f5a{SSL-http/1.1}{10.0.0.8:443}: java.net.BindException: Address already in use: bind

If I’m reading that correctly, it’s set to use port 8443, but then reports an error as 443 is already in use.
Any ideas?

Preetty confusing error message sequence :hushed:

And another thought is it’s Java, so your problem should be agnostic to that you’re on Windows.

Looking at the source code and I think it’s spotted though: https://github.com/metabase/metabase/blob/v0.30.0/src/metabase/core.clj#L206

Try setting the MB_JETTY_SSL_PORT instead of the environment variable you picked.

I’m curious :monkey_face: … George … - did it resolve the issue?

Yes, you’re entitled to enjoy your weekend first!

I can’t test until Moday lunchtime. The dashboards are part of a system that allows sending and receiving text messages to field workers.

It’s working now. Thanks for your help.

Hello there,

I’m new here.
I’m installing metabase in windows, tried to configure SSL, looks like i successfully create the keystore with the certificate.

How to open the metabase page using the https in local?
I configured the port to 8443.
I tried localhost:8443 , but couldn’t open the page.
Here’s a screenshot of the parameter.
metabase_set

Could it be i missed something?

You can’t use localhost with SSL. Try with the name on the certificate. So if your certificate is for mymetabase.me.com, you’d need to use https://mymetabase.me.com:8443

If that can’t connect, check your DNS resolves mymetabaes.me.com top the server.

Also, when metabase starts, are there any errors.

Finally, any what error do you get in teh browser if none of the above

@AndrewMBaines just wondering are wildcard certs supported?

I’ve never used a wildcard certificate. They always look like a great idea until you see the price!
I don’t see why they wouldn’t just work provided the wildcard matches the address. That would be Jetty specific rather than Metabase.