Stuck at the beginning - can't add a database (no such file or directory)

I have got Metabase up and running on Docker, and of course I now want to add a database. I've created an SQLite database by importing some CSV tables, so it's all good to go. This database is currently sitting on my laptop, and I've also uploaded it to my server.

In my docker compose file, I included some bind mounts, so that the volumes section of the Metabase container service is:

    - /dev/urandom:/dev/random:ro
    - /home/amca/Docker/Metabase:/metabase-data
    - /home/amca/Docker/Metabase/plugins:/plugins

(These directories were all created when the container started, so I know they're there!)

However, since the Filename box in the Add Database page doesn't include a file browser, I'm not at all sure whether the file should be on my local hard drive, or in the above directory on my VPS, or somewhere else. In fact I've tried all of these, and each one produces the same error: that there is no such file or directory.

I've read through the SQLite documentation for Metabase, and I've checked the logs with docker logs metabase. But there's not much more information, other than a Java exception: /path/to/database.db (No such file or directory)

So I'm currently a bit stuck, and would welcome any advice! Where should the database file be so that Metabase can access it?

Many thanks,

By the way, here's the diagnostic info:

  "browser-info": {
    "language": "en-GB",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.22+7",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "11.0.22",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.22+7",
    "": "Linux",
    "os.version": "5.4.0-37-generic",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "16.2 (Debian 16.2-1.pgdg120+2)"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.7.2"
    "run-mode": "prod",
    "version": {
      "date": "2024-03-14",
      "tag": "v0.49.0",
      "hash": "46c668b"
    "settings": {
      "report-timezone": null

I guess it's permissions, have you checked file permissions?

Many thanks - and sorry for not replying earlier; I must have missed the notification.

I run docker as myself (not as root, but I am in the "docker" group), but the various directories created by Metabase are owned by any of root, me, and systemd-coredump (which has uuid 999; that is one more than docker, which has uuid 998.) All this is on Ubuntu 20.04 LTS.

What permissions is the database file supposed to have - and who should be its owner?

Thank you again,