Surface individuals data with Number Type not offering option


I am trying to use this models' feature but i am facing an issue with Snowflake.
I have a source table with an ID typed to INTEGER (postgres table)
I use Snowflake as an intermediate table and the ID INTEGER column is casted to the SF specific type named NUMBER

When I open metabase, the column is typed: type/Number instead of type/Integer

As a result, I cannot use the feature mentionned above (as per documenation - i.e: it needs a type/Integer column). the option "Surface individual records..." is not appearing in the right menu

I have tested on a sample table with proper INTEGER type, and it works like a charm.

Is there a solution to make it works with NUMBER ?
Is there a workaround someone used for this (i.e force cast to type/Integer) ?
Should I do some customization in Snowflake or is it just a limitation of Metabase ?

Thanks for your help