Sync database schema fail

"browser-info": {
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/93.0.4577.82 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "GBK",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.9+11",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "",
"java.version": "11.0.9",
"": "Eclipse OpenJ9 VM",
"java.vm.version": "openj9-0.23.0",
"": "Windows 10",
"os.version": "10.0",
"user.language": "zh",
"user.timezone": "Asia/Shanghai"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"date": "2021-09-21",
"tag": "v0.40.5",
"branch": "release-x.40.x",
"hash": "042a36e"
"settings": {
"report-timezone": null

Hi @beta
If it fails, then provide the logs - Admin > Troubleshooting > Logs.
Is the Impala driver even compatible with Metabase 0.40.5?
Post the driver repo link and version you are using. If the driver has not been updated for a long time, then that's likely the problem and you should check if there's open issues on the driver repo.

Retry a few times, Successful,thanks

@beta The sync process takes time. It can take anywhere between a couple of seconds and many minutes. Check the log to see the process.

Manual Click Synchronization will report an error, wait until the automatic update will succeed, what is the reason?

@beta Unless you provide logs, then I have absolutely no idea. There is no difference between manual and automatic sync. They both run the same process.

Manual synchronization log:

@beta Well, you are clearly not running Metabase with the default Java parameters. Remove the log4j parameter or update it to fit the version of Metabase you're using.

Isn't this?


  1. I have no idea if you have environment variables defined.
    Type set to see all environment variables defined in the console you're currently using.
  2. Change Java to what is recommended (HotSpot, not OpenJ9):
  3. Migrate away from H2 if you're using Metabase in production:

@beta Please use Docker or Linux, seems to be better for you. Something must be wrong in your setup.