Sync problem with PostgreSQL JSONB data type

I am trying out Metabase (v0.43.1) with data storage in PostgreSQL and data source in PostgreSQL. When I try to access some tables from 'Browse Data' option, I get "No fields found for table 'xyz'". I tried to sync manually from 'Admin->Databases' option. I get the following error-

Error syncing Fields for Table 'Table 14 '''
org.postgresql.util.PSQLException: ERROR: column xyz.updatedby does not exist
Hint: Perhaps you meant to reference the column "xyz.updatedBy".

Errors are showing for fields with the following definition:

  1. Field name like 'updatedBy' (case-sensitive)
  2. Field type 'jsonb'.
  3. Field contains normalized user information

User information example:

    "dob": "1999-04-15T03:47:46.000Z",
    "mycid": "1234567890123",
    "tax": null,
    "role": "viewer",
    "email": "",
    "phone": "+601234567890",
    "gender": "male",
    "userId": "01FWZJJ0FW90AABC2R9YFFEBWD",
    "fullName": "A",
    "createdAt": "2022-02-28T01: 18: 05.029Z",
    "profilePicture": ""

Thanks for your help.

Hi @netsurfer002
Sounds like you are seeing a combination of these issues - upvote by clicking :+1: on the first post:

@flamber I have tried v0.40.7. I didn't face problems like v0.43.1. v0.40.7 is running without any problem.

@netsurfer002 JSON unfolding was added in 0.43.0, so it would not be a problem in previous versions.

1 Like