t.templateTagsMap is not a function

I just revert back to a previous edit in a question.

Then when I opened the dashboard containing the question, I got the following

t.templateTagsMap is not a function

How can I solve this ?

Hi @Mohammad_Abdallah

  1. Post "Diagnostic Info" from Admin > Troubleshooting.
  2. Post the full browser console log

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.16+8-post-Ubuntu-0ubuntu120.04",
"java.vendor": "Ubuntu",
"java.vendor.url": "https://ubuntu.com/",
"java.version": "11.0.16",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.16+8-post-Ubuntu-0ubuntu120.04",
"os.name": "Linux",
"os.version": "5.4.0-124-generic",
"user.language": "en",
"user.timezone": "Etc/UTC"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"date": "2022-08-04",
"tag": "v0.44.0",
"branch": "release-x.44.x",
"hash": "d3700f5"
"settings": {
"report-timezone": null


Upgrade to latest release: https://github.com/metabase/metabase/releases/latest

Migrate away from H2 if you are using Metabase in production: https://www.metabase.com/docs/latest/installation-and-operation/migrating-from-h2

And provide more information about your problem, so it's possible to understand and help you.

is there a way to solve it before making the update ?

@Mohammad_Abdallah You are simply not providing enough information to understand what the problem is, so I cannot answer if the problem will be fixed by upgrading.

Try providing exact steps to reproduce the problem you are having.

Let me clarify

I have a dashboard
Inside the dashboard I have many questions (cards)
I tried to edit a question (BY Reverting back to previous edit by another person )
After that I was not able to open the whole dashboard
Once I try to open the dashboard I got the following

t.templateTagsMap is not a function

@Mohammad_Abdallah Okay, I cannot reproduce on latest release.

@Mohammad_Abdallah Hey, I just got this error and tried to edit the question that I reverted and saved it with the alterations that I had done previously. And it worked.
I don't really know what happend, but maybe the dashboard tries to look for the question and when you revert it the dashboard gets cofused. :smiley: