Table details are missing when using GET /api/table/:id/query_metadata

Good day everyone,

I often access a table's database details using the endpoint * GET /api/table/:id. The call returns a json that would contain the child key "details" inside the key "db". Within "details", I would find e.g. the table's database' host, db name, user, etc.

To my surprise, when using the endpoint * GET /api/table/:id/query_metadata with the same table id, the call returns a json with empty database details.

I have tried adding paramenters {"include_hidden_fields": True, "include_sensitive_fields": True} to the above endpoint , but still no db details are shown.

I have replicated this behaviour using tables from both Redshift and BigQuery.

Am I missing something? Thank you in advance!

Hi @9167597615
The best way to learn the API, is to just use Metabase while having your browser developer Network-tab open and looking at the request, and what data is being send/received.
Parameters for a GET request is in the URL.