Table names are wrong

I use Metabase 0.33.6 with Postgresql 9.5.17.
I have such names of tables and views in Postgres:
image

But metabase sees it very differently:


And makes it impossible to read.
It looks like a bug, and it looks like cosset by “_” in the name of table…?

Any ideas how to solve it?

Trouble shoot data:
{
“browser-info”: {
“language”: “en-US”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“java.runtime.name”: “Java™ SE Runtime Environment”,
“java.runtime.version”: “1.8.0_231-b11”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “http://java.oracle.com/”,
“java.version”: “1.8.0_231”,
“java.vm.name”: “Java HotSpot™ Client VM”,
“java.vm.version”: “25.231-b11”,
“os.name”: “Windows Server 2019”,
“os.version”: “10.0”,
“user.language”: “en”,
“user.timezone”: “Europe/Helsinki”
},
“metabase-info”: {
“databases”: [
“h2”,
“postgres”
],
“hosting-env”: “unknown”,
“application-database”: “h2”,
“run-mode”: “prod”,
“version”: {
“tag”: “v0.33.6”,
“date”: “2019-11-19”,
“branch”: “release-0.33.x”,
“hash”: “be1e0e1”
},
“settings”: {
“report-timezone”: null
}
}
}

I have the exact same issue with an MS SQL database.

It’s nearly impossible to navigate the database in Metabase as we have quite a lot of tables, but can’t search for them as the names are completely random.

There’s no _ in our table names, so that’s definitely not the source.

Admin - Settings - General

Disable

FRIENDLY TABLE AND FIELD NAMES

4 Likes

Thanks - that helped.
Note: after change it gave no effect, only removing and adding DB again helped.

1 Like