Table Visualization: Avoid display numeric column as interval

Hi,

When I create a “Custom Question” and group by a numeric value the column always display as an interval, not a single value, like this example. The actual year is 2020 and Month is 8, but its displayed as 2020-2025 and 8-10 respectively

There is a way to avoid this behavior?

image

Hi @lucas.yoshida
Please post “Diagnostic Info” from Admin > Troubleshooting.
And which database you’re querying.

What is the Field Type in Admin > Data Model > (db) > (table) > (column) :gear:

  • Database: Snowflake
  • Both fields Type are “Number” (Common)
  • Diagnostic Info
    {
    “browser-info”: {
    “language”: “pt-BR”,
    “platform”: “Win32”,
    “userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.121 Safari/537.36”,
    “vendor”: “Google Inc.”
    },
    “system-info”: {
    “file.encoding”: “UTF-8”,
    “java.runtime.name”: “OpenJDK Runtime Environment”,
    “java.runtime.version”: “11.0.8+10”,
    “java.vendor”: “AdoptOpenJDK”,
    “java.vendor.url”: “https://adoptopenjdk.net/”,
    “java.version”: “11.0.8”,
    “java.vm.name”: “OpenJDK 64-Bit Server VM”,
    “java.vm.version”: “11.0.8+10”,
    “os.name”: “Linux”,
    “os.version”: “4.14.109-80.92.amzn1.x86_64”,
    “user.language”: “en”,
    “user.timezone”: “GMT”
    },
    “metabase-info”: {
    “databases”: [
    “mysql”,
    “snowflake”,
    “mongo”
    ],
    “hosting-env”: “elastic-beanstalk”,
    “application-database”: “postgres”,
    “application-database-details”: {
    “database”: {
    “name”: “PostgreSQL”,
    “version”: “10.6”
    },
    “jdbc-driver”: {
    “name”: “PostgreSQL JDBC Driver”,
    “version”: “42.2.8”
    }
    },
    “run-mode”: “prod”,
    “version”: {
    “date”: “2020-08-17”,
    “tag”: “v0.36.4”,
    “branch”: “release-0.36.x”,
    “hash”: “196c1f6”
    },
    “settings”: {
    “report-timezone”: null
    }
    }
    }

@lucas.yoshida Change Field Type to “Category” instead, since it’s not a field you want binning on.

1 Like

Thanks! It worked