The problem:filename or extension is too long

hello,I run the command:lein ring server
Problems arise: CreateProcess error=206,filename or extension is too long
How to solve it?

1 Like

Hi @bao2007happy
You need to provide much more information.
Which OS are you using - and are you running the lein command in a directory with a very long path?
Try running these commands and provide the output:

java -version
nodejs --version
lein --version
yarn --version
lsb_release -d
git log -1 --format="commit %H"
git status | head -1

hello,My OS is windows.
My running environment meets the requirements of metabase.
JDK v1.8.0_171
nodejs v12.11.1
lein v2.9.1
yarn v1.19.0
Git is not associated with the current project
It seems to be a Windows problem. I don’t know if there is a solution

Well, there has been a known limitation of path in Windows since forever - think the limit of the entire length of a path is 256 characters. I don’t think it was been fixed and will likely not be fixed until they change file system, since I think it’s a limitation of NTFS.

yeah,By modifying the windows file path limit, it has been solved,thank you!

I have tried to change the path of the Metabase source folder still getting the same error.
What path do we need to change in order to fix the issue?

e[35m[include-drivers middleware] including these drivers: #{“google” “bigquery” “mongo” “sqlite” “sparksql” “presto” “druid” “redshift” “sqlserver” “googleanalytics” “snowflake”}e[0m
Error encountered performing task ‘run’ with profile(s): ‘base,system,user,provided,dev,run’ Cannot run program “java” (in directory “C:\metabase-master”): CreateProcess error=206, The filename or extension is too long
at java.base/java.lang.ProcessBuilder.start(
at java.base/java.lang.ProcessBuilder.start(

@jeevang You would probably need to try WSL2 or a different OS if you’re hitting limitations in Windows.