Time display without time zone


Now I see time values as “19:19:54.000+02:00” - how I can change format to “19:19:54”.
In filed settings it is already chosen Show the time: HH:MM:SS, but it still shows with timezone.
I am using metabase with Postgresql.

Hi @LukasRa
Which version of Metabase? Post the Diagnostic Info from Admin > Troubleshooting.
Which version of Postgres?
What is the Field Type of the column? Admin > Data Model > (db) > (table) > (column) :gear:

EDIT: You say “Now I see…” - does that mean that you saw regular format in earlier versions? Which version?


Metabase 0.33.5
Postgresql 9.5.17
Field Type of the column was not set. I selected now Creation timestamp, but it did not helped.
This is SQL question, and query of this field looks like this:
tikrinimo_laikas::time(0) without time zone as “perkelimo_laikas”

No, it is new installation, and I dont know how it was in earlier versions.

Diagnostic info:
“browser-info”: {
“language”: “en-US”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.97 Safari/537.36”,
“vendor”: “Google Inc.”
“system-info”: {
“java.runtime.name”: “Java™ SE Runtime Environment”,
“java.runtime.version”: “1.8.0_231-b11”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “http://java.oracle.com/”,
“java.version”: “1.8.0_231”,
“java.vm.name”: “Java HotSpot™ 64-Bit Server VM”,
“java.vm.version”: “25.231-b11”,
“os.name”: “Windows Server 2019”,
“os.version”: “10.0”,
“user.language”: “en”,
“user.timezone”: “Europe/Helsinki”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “h2”,
“run-mode”: “prod”,
“version”: {
“tag”: “v0.33.5”,
“date”: “2019-11-08”,
“branch”: “release-0.33.x”,
“hash”: “d9d6f72”
“settings”: {
“report-timezone”: null

@LukasRa It sounds like a timezone issue. Can you post the answers to the 6 points from the troubleshooting guide?
Also, latest release is, since 0.33.5 had some build problems, so please use that version.