Time in Metabase is out by 2 hours

I wonder if anyone can help me. I am using Metabase v0.30.4 and I am running mysql database.
In the database, the timezone is “SYSTEM” and my server is set to (UTC+02:00) Harare, Pretoria

In Metabase/admin/ my reporting timezone is database default

In the database field the time is 2018-11-01 07:58:08 and in metabase data its Thursday, November1, 2018 9:58AM. It seems to be 2 hours out on all records in the database.

If I change the reporting time zone to Africa/Harare, its still the same and now i get a sql timezone incorrect in the logs.

Just to double-check, have you read over the timezone FAQ article? https://www.metabase.com/docs/latest/troubleshooting-guide/timezones.html

Hi Maz

I have checked the documentation but cant resolve or pin point the problem. My database is using South afrcan standard time, @@system_time_zone
South Africa Standard Time. In the reporting time zone there is no such timezone. If I use Africa/Harare etc. Nothing changes.

@maz

I have now upgraded to the latest Metabase version 0.31.0 and now I can filter on dates at all. Please see below log and dashboard. I have played with all the different formating options but still no data will filter on date filter.

Error is status failed, Dont Know what to do with Literal field “Helpdesk_Created_Time” Type text but its a date time field

@maz

Below is my time in sql. It has a timezone in sql.

image

@maz

If I set the reporting time zone to “UTC” then the time is correctly displayed. This is odd because the database is set to +02:00 SAST and if i set this in the Reporting zime zone then the time in metabase is increased by two hours. If I set it to UTC it then is -02:00 and the correct time is produced.

Please can you assist me with the issue that I am having after upgrading to the new version.

Possibly related to

@maz

Did you find a possible to this issue I am having?

Hi, I know this is a pretty old issue and was wondering if there was any resolution or if someone found a fix for this. I have read all documentation and tried everything, yet I am still seeing an offset of 2 hours on questions.

  1. I have checked the timezone on my server running metabase
  2. I have checked the timezone on the server holding the data
  3. I have checked the mysql timezone on the server holding the data
  4. I have checked the localization settings in metabase

All of the above correspond with each other, yet I am still seeing the offset.

Any help would be greatly appreciated.

Thanks

@Surge You are most likely not seeing anything related to this topic, since it's so old.

Create a new topic, provide links to what you have read and instead of writing what you have checked then provide your timezones and "Diagnostic Info" from Admin > Troubleshooting.

1 Like