Timezone issue

Hi Metabase community,

We have created connection in Metabase for MySQL but every time occurs below error in metabase logs.
We have checked timezone both server and it have same time zone on both
we are tried to resolved this issue but we got failed. So need a solution from your end.

Diagnostic Logs:

"browser-info": {
"language": "en-GB",
"platform": "Linux x86_64",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.16+8-LTS",
"java.vendor": "Red Hat, Inc.",
"java.vendor.url": "https://www.redhat.com/",
"java.version": "11.0.16",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.16+8-LTS",
"os.name": "Linux",
"os.version": "3.10.0-1160.36.2.el7.x86_64",
"user.language": "en",
"user.timezone": "Asia/Kolkata"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MySQL",
"version": "5.7.35"
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.7.5"
"run-mode": "prod",
"version": {
"date": "2022-07-20",
"tag": "v0.45.0-SNAPSHOT",
"branch": "master",
"hash": "b30e2e5"
"settings": {
"report-timezone": "Asia/Kolkata"

Hi @Twinkal
You are using a custom/developer build. Try using the official releases: https://github.com/metabase/metabase/releases/latest

Run this query directly on MySQL SET @@session.time_zone = 'Asia/Kolkata';

If you are getting an error there, then follow the steps in the description here:

Hi Flamber,

Thanks for your quick reply.
We have checked this solution but not resolved yet. Kindly give us any other solution? if you have.

@Twinkal Perhaps you're using such an old version of Redhat that timezones are not available.
Then you need to download them, as noted in the MySQL documentation:

MySQL doesn't come with timezones, you need to add those yourself. It's not a bug in Metabase, it's a problem with MySQL. Try asking in a MySQL specific forum.