Treating decimal as numeric quantity from Grisbi data

I am running the latest Metabase from docker using the following command:

sudo docker run --platform linux/amd64 -d -p 3000:3000 --name metabase metabase/metabase-enterprise-head:latest

I have Grisbi (personal financial account manager) data that has been exported to CSV and imported to an Sqlite file which I am trying to access through Metabase. A sample entry looks like the following:

Transactions;"Account name";"Split";Date;Value date;"Cheques";"Financial year";"C/R";"Payee";Credit;Debit;Balance;"Category";"Sub-categories";"Budgetary lines";"Sub-budgetary lines";"Notes";"Voucher";"Reconciliation number";"Bank references";
...
8574;"Bank DB";"";23/02/2021;;"";"";"";"Reimbursements";2000.00;0;2000.0;"Misc. income";"Refunds";"";"";"Internet";"";"";"";

The numbers used commas which I removed using sed. I was able to set Date as Creation Date in the Data Model.

  1. But, when I try to set Credit as Currency, I am not able to see the filter option to select Greater than when asking a question. Why is this so?

  2. There are values such as 0, 0.00 and 100.00 in the credit column. Are these decimal values valid?

  3. When I try to visualize a line chart between Credit and Date, I get a blank page and an error that says, "Data includes missing dimension values". What does this mean?

Hi @skmessage
Without knowing how you have imported the data into SQLite, meaning which column types you are using in SQLite, then it's not possible to know, but my first guess is that they are string-based.
Also, dates in databases should be stored as YYYY-MM-DD and preferably as DATE column type.

1 Like

I used the following to import the data to Sqlite:

sqlite> .mode csv
sqlite> .separator ";"
sqlite> .import bank-db.csv data

I updated the date model to use M-D-YYYY format in the Data Model admin page, and it picked it fine. It even shows the calendar icon next to the field. But, this is not the case with the Credit or Debit fields when selecting a numeric type.