Trouble upgrading to 38

“browser-info”: {
“language”: “en-us”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.3 Safari/605.1.15”,
“vendor”: “Apple Computer, Inc.”
“system-info”: {
“file.encoding”: “UTF-8”,
“”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “”,
“java.vendor”: “Ubuntu”,
“java.vendor.url”: “”,
“java.version”: “”,
“”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “”,
“”: “Linux”,
“os.version”: “5.4.0-62-generic”,
“user.language”: “en”,
“user.timezone”: “America/New_York”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “mysql”,
“application-database-details”: {
“database”: {
“name”: “MariaDB”,
“version”: “10.3.25-MariaDB-0ubuntu0.20.04.1”
“jdbc-driver”: {
“name”: “MariaDB Connector/J”,
“version”: “2.6.2”
“run-mode”: “prod”,
“version”: {
“date”: “2021-01-13”,
“tag”: “v0.37.6”,
“branch”: “release-x.37.x”,
“hash”: “344e5e0”
“settings”: {
“report-timezone”: “US/Eastern”

You can see the Metabase version posted in the above, however I’ve downloaded the new v38 jar, stopped the metabase service, replaced the jar file, restarted the service as well as rebooting the server (all it does is run Metabase). I’ve verified on the filesystem that /opt/metabase/metabase.jar has a date of Feb 16 (and size of 217419419 bytes) but that doesn’t seem to be the jar that’s running?

I’ve also confirmed in the service description file that this is the correct location:
ExecStart=/usr/bin/java -jar /opt/metabase/metabase.jar

What else can I try here?

Hi @Greg
Then you have multiple processes running, or perhaps you have a reverse-proxy cache?
Check with ps aux | grep -i metabase
And then killall INPUT-THE-PROCESS-ID-HERE of any running process related to Metabase
And then systemctl status metabase - which should be “not running” (expecting that you have called the service metabase)
And then systemctl start metabase

Wow - embarrassing. I had upgraded the .jar on an old server (that I’ve now deleted). Took me way too long to figure that out, but I’m good. The upgrade process was smooth and painless once I was doing it in the right place!

1 Like